bugGNU gettext - Bugs: bug #35527, xgettext only partially extracts a...

 
 

bug #35527: xgettext only partially extracts a string if \0 is in the string

Submitted by:  None
Submitted on:  Tue 14 Feb 2012 01:35:50 PM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: Not a Bug
Privacy: PublicAssigned to: None
Open/Closed: Closed

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 14 Feb 2012 04:57:08 PM UTC, comment #1:

oh never mind. I didn't see it had already been marked as 'not a bug' because I only displayed the 'open' bugs. Feel free to close the bug and sorry for the noise.

Anonymous
Tue 14 Feb 2012 01:35:50 PM UTC, original submission:

xgettext -a only extracts part of a string if the character \0 is in it.

This happens for example in BusyBox 1.19.3 in coreutils/stty.c:

const char *fmt_str = "%lu %lu\n\0ispeed %lu baud; ospeed %lu baud;";

The result that xgettext returns is "%lu %lu\n"

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by m1gu3l (Updated the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 01 Mar 2013 08:12:38 PM UTCm1gu3lOpen/ClosedOpen=>Closed
      Summaryxgettext only partially extracts a string if \\0 is in the string=>xgettext only partially extracts a string if \0 is in the string
    Thu 28 Feb 2013 10:28:21 AM UTCm1gu3lStatusNone=>Not a Bug
      Summaryxgettext only partially extracts a string if \\0 is in the string=>xgettext only partially extracts a string if \0 is in the string

    Back to the top


    Powered by Savane 3.1-cleanup