bugmake - Bugs: bug #33129, MAKEOVERRIDES reset after a...

 
 

bug #33129: MAKEOVERRIDES reset after a recursive 'make restart'

Submitted by:  None
Submitted on:  Tue 19 Apr 2011 08:35:21 PM UTC  
Votes:  100  
 
Severity:  3 - Normal Item Group:  Bug
Status:  Duplicate Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  3.82 Operating System:  Any
Fixed Release:  None Triage Status:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Mon 10 Sep 2012 02:24:54 PM UTC, comment #10: 

Thanks for the info Paul.

I've been building make using the latest source tarball from http://ftp.gnu.org/gnu/make/ because RHEL 6.3 comes with make-3.81 which is not sufficient for building some latest versions of gcc and binutils.

Is there a way to get the latest stable source code with all the latest bugfixes applied?

Maxim Yegorushkin <max0x7ba>
Mon 10 Sep 2012 02:10:26 PM UTC, comment #9: 

The one in bug #30723 is correct and has been applied to the codebase (and to various distro versions of make) for quite a while.  That fix reflects the way make worked in 3.81.

Exporting this variable is less correct because that special variable name is written specifically to be internal to make.  It's not a valid shell variable name, for example, so it can't be used in the shell.

Paul D. Smith <psmith>
Project Administrator
Mon 10 Sep 2012 02:02:31 PM UTC, comment #8: 

I meant https://savannah.gnu.org/bugs/?30723 fixes it differently.

Maxim Yegorushkin <max0x7ba>
Mon 10 Sep 2012 01:52:20 PM UTC, comment #7: 

The patch from https://savannah.gnu.org/bugs/?33129 fixes it differently. The patch here is a bit less intrusive: it exports a variable that was missing in the environment when restarting.

Which one should be preferred?

Maxim Yegorushkin <max0x7ba>
Mon 10 Sep 2012 01:40:49 PM UTC, comment #6: 

Sorry.  It's a dup of bug #30723

Paul D. Smith <psmith>
Project Administrator
Mon 10 Sep 2012 08:43:00 AM UTC, comment #5: 

Are you sure you posted the correct duplicate bug 30273? Because it seems totally unrelated.

Maxim Yegorushkin <max0x7ba>
Mon 10 Sep 2012 05:19:48 AM UTC, comment #4: 

How is this a duplicate of 30273? It looks like that bug is related to permission settings affecting SELinux.

Anonymous
Mon 10 Sep 2012 04:39:37 AM UTC, comment #3: 

This is a duplicate of bug #30273

Paul D. Smith <psmith>
Project Administrator
Sun 29 Jul 2012 06:57:50 PM UTC, comment #2: 

I am no expert in GNU make internals, but it seems that a variable named -*-command-variables-*- which MAKEOVERRIDES refers to doesn't get exported into the environment.

The attached patch fixes the issue.

(file #26285)

Maxim Yegorushkin <max0x7ba>
Thu 15 Mar 2012 06:01:13 PM UTC, comment #1: 

This seems like a fairly significant bug to me; surprised it hasn't had more attention. Essentially this means that command-line variable overrides are lost whenever doing a sub-make step that rebuilds an included makefile. This bug is keeping me stuck at version 3.81

Zach Gorman <nvzgorman>
Tue 19 Apr 2011 08:35:21 PM UTC, original submission:  

Hi,

It seems there is a problem with MAKEOVERRIDES that is reset when a recursive make restarts itself (after rebuilding an included Makefile).

The following Makefile:
all:; @echo M1=${MAKEOVERRIDES}; rm -f test.mk; ${MAKE} fail
fail:; @echo M2=${MAKEOVERRIDES}; rm -f test.mk
-include test.mk
test.mk:; @touch $@

produces the following output when run with `make VAR=x`:
M1=VAR=x
M2=

Commenting out either the '-include' or the test.mk rule will output:
M1=VAR=x
M2=VAR=x

I'm not sure which is wrong, but it seems at least inconsistent.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #26285:  restart.patch added by max0x7ba (686B - text/x-patch)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by psmith (Posted a comment)
  • -email is unavailable- added by max0x7ba (Updated the item)
  • -email is unavailable- added by jbusco (Voted in favor of this item)
  • -email is unavailable- added by nvzgorman (Posted a comment)
  • -email is unavailable- added by nvzgorman (Voted in favor of this item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 100 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2012-09-10 psmith StatusNone => Duplicate
        Open/ClosedOpen => Closed
    2012-07-29 max0x7ba Attached File- => Added restart.patch, #26285
    2012-03-15 jbusco Carbon-Copy- => Added jbusco
    2012-03-15 nvzgorman Carbon-Copy- => Added nvzgorman

    Back to the top


    Powered by Savane 3.5