bugGNU TeXmacs - Bugs: bug #30301, link images takes a long time with...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #30301: link images takes a long time with many images

Submitted by:  Sam Liddicott <samjam>
Submitted on:  Wed 30 Jun 2010 08:24:22 AM UTC  
 
Category: Qt portPriority: 5 - Normal
Item Group: ErrorStatus: Fixed
Privacy: PublicAssigned to: Joris van der Hoeven <vdhoeven>
Originator Name: Open/Closed: Closed
Release: Release: None
Fixed Release: NoneFixed Release: 
Keywords: 

Thu 28 Nov 2013 11:20:33 AM UTC, comment #5:

Since I do not have recent bad news, I am closing this bug.

Joris van der Hoeven <vdhoeven>
Project AdministratorIn charge of this item.
Fri 09 Sep 2011 04:59:27 PM UTC, comment #4:

Should I close this bug, or is the behaviour still partially incorrect?

Joris van der Hoeven <vdhoeven>
Project AdministratorIn charge of this item.
Wed 28 Jul 2010 06:58:39 AM UTC, comment #3:

This is no longer happening with SVN head

Sam Liddicott <samjam>
Project Member
Wed 30 Jun 2010 08:40:29 AM UTC, comment #2:

More detail:

I'm using the QT build from SVN.

When the open dialog appears (to select my image) If I first click on a file or folder on the right-hand side of the dialog then I get the long delay. If I first click on one of the icons on the left (called "Look in") then I don't get the delay.

So it looks like customization of the dialog that is not behaving consistently. Possibly if that were fixed then the delay would always occur, so this may be two bugs.

Sam Liddicott <samjam>
Project Member
Wed 30 Jun 2010 08:34:19 AM UTC, comment #1:

The long delay and "gs" invocation only occurs if when I see the dialog box to select the image to insert I immediately navigate to the sub-directory that contains all of the many images.

If I first navigate up one level, then back to the project folder and then to the sub-folder with the images, then the long delay does not occur.

This work around will do for now, but something screwy is going on.

Sam Liddicott <samjam>
Project Member
Wed 30 Jun 2010 08:24:22 AM UTC, original submission:

If a document contains a lot of images (linked images in my case) then inserting another linked image takes a LONG time.

The commands that are running on the system taking all the CPU are of the form:

gs -dQUIET -dNOPAUSE -dBATCH -dSAFER -sDEVICE=png16m -dGraphicsAlphaBits=4 -dEPSCrop -g78x98 -r10x10 -sOutputFile=/home/sam/.TeXmacs/system/tmp/tmp_193003640.png /home/sam/Projects/projectname.pdf

Sam Liddicott <samjam>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by vdhoeven (Updated the item)
  • -unavailable- added by samjam (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 28 Nov 2013 11:20:33 AM UTCvdhoevenStatusNone=>Fixed
      Assigned toNone=>vdhoeven
      Open/ClosedOpen=>Closed
    Sat 03 Jul 2010 08:52:26 AM UTCvdhoevenCategoryNone=>Qt port
      Item GroupNone=>Error

    Back to the top


    Powered by Savane 3.1-cleanup