bugPSPP - Bugs: bug #24533, Wrong dll name

 
 

bug #24533: Wrong dll name

Submitted by:  Harry Thijssen <unknown_one>
Submitted on:  Sun 12 Oct 2008 08:42:09 AM UTC  
 
Category:  Compilation/Portability Severity:  5 - Average
Status:  Wont Fix Assigned to:  None
Open/Closed:  Closed Release:  None
Effort:  0.00

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 24 Feb 2009 02:57:01 AM UTC, comment #10: 

This library no longer exists, so closing this item.

John Darrington <jmd>
Project Administrator
Sat 07 Feb 2009 11:14:03 PM UTC, comment #9: 

Hopefully this problem will go away when we stop depending on libglade and use GtkBuilder instead.

John Darrington <jmd>
Project Administrator
Fri 06 Feb 2009 01:39:56 AM UTC, comment #8: 

See also bug #25491

John Darrington <jmd>
Project Administrator
Tue 14 Oct 2008 07:17:51 PM UTC, comment #7: 

>The new tarball builds without problems on Cygwin and openSUSE.
>However, the problem in Cygwin stays the same :-(


That's very sad.

Thanks for trying it out!

Ben Pfaff <blp>
Project Administrator
Tue 14 Oct 2008 07:10:29 PM UTC, comment #6: 

The new tarball builds without problems on Cygwin and openSUSE. However, the problem in Cygwin stays the same :-(

Harry Thijssen <unknown_one>
Tue 14 Oct 2008 12:52:52 AM UTC, comment #5: 

I wonder whether the problem is solved in a newer version of libtool.  I used libtool 1.5.26 (the version currently in Debian "unstable") to produce the PSPP release tarballs, but libtool 2.2.2 is available in Debian "experimental".

So here's PSPP 0.6.1, but produced with libtool 2.2.2: ftp://alpha.gnu.org/gnu/pspp/pspp-0.6.1+libtool-2.2.2.tar.gz

Ben Pfaff <blp>
Project Administrator
Mon 13 Oct 2008 06:53:34 AM UTC, comment #4: 

In my opinion only very few users will generate MSWindows executables and there is an easy workaround. If the developer is aware of this issue!

If it is not easy to solve, I think the projectteam shouldn't spend valuable development time to try to solve this. It should be sufficient to place this issue on the list with known problems and change the Severity to low.

Harry Thijssen <unknown_one>
Mon 13 Oct 2008 01:47:30 AM UTC, comment #3: 

I guess this is really a automake/libtool issue.

John Darrington <jmd>
Project Administrator
Sun 12 Oct 2008 10:29:24 AM UTC, comment #2: 

Unfortunately I didn't find a libpsppire.dll. Besides as far as I know, symbolic links don't work on MSWindows.

Harry Thijssen <unknown_one>
Sun 12 Oct 2008 10:12:00 AM UTC, comment #1: 

When you run "make install", a symbolic link should be created from libpsppire.dll to libpsppire-0.dll

I recommend you do:

 make DESTDIR=/some/temporary/directory install

then create your "setup" from the files in /some/temporary/directory

John Darrington <jmd>
Project Administrator
Sun 12 Oct 2008 08:42:09 AM UTC, original submission:  

When PSPPire is build on MSWindows, the file cygpsppire-0.dll (cygwin) or libpsppire-0.dll (mingw) is created. However the psppire uses cygpsspire.dll or libpsppire.dll.

A work around is renaming it after the build before creating a setup.

Harry Thijssen <unknown_one>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by blp (Posted a comment)
  • -email is unavailable- added by jmd (Posted a comment)
  • -email is unavailable- added by unknown_one (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2009-02-24 jmd Open/ClosedOpen => Closed
    2009-02-07 jmd StatusNone => Wont Fix

    Back to the top


    Powered by Savane 3.5