bugmake - Bugs: bug #24488, phony targets are case insensitive...

 
 

bug #24488: phony targets are case insensitive with case insensitive file system

Submitter:  Stepan Kasal <kasal>
Submitted:  Wed 08 Oct 2008 05:50:36 PM UTC
 
Severity:  3 - Normal Item Group:  Enhancement
Status:  Not A Bug Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  4.0 Operating System:  Any
Fixed Release:  None Triage Status:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Mon 01 Jun 2009 05:10:53 PM UTC, comment #3: 

Actually, with gmake 3.81 on windows, ".PHony" works just the same as ".PHONY".

Anonymous
Mon 01 Jun 2009 01:28:17 PM UTC, comment #2: 

Hello, thank you for answering my report.

> PHONY is [..] also used to mark real files that could appear
> on the filesystem as "always rebuilt" for various reasons.


Oh, that explains why things like "make ./all" always work.

With your explanation, I see that the current state is consistent and I can now see that keeping things as they are is a plausible option.

That, together with the impementation diffuculties, makes me to agree with you.  Please close as "Not A Bug."

Stepan Kasal <kasal>
Mon 01 Jun 2009 11:28:28 AM UTC, comment #1: 

I'm not convinced that this request is something we actually want to implement; .PHONY is not only used for completely phony targets (where using case-sensitive matching would make sense), it's also used to mark real files that could appear on the filesystem as "always rebuilt" for various reasons.  In this case you would want them to be treated case-insensitively.

Even if we wanted to do this, there's no easy way to do it: the --enable-case-insensitive flag is a compile-time flag which changes the entire behavior of make at a code level.  There is no facility in the codebase today to track case-insensitive flags on a per file target.

As for special targets not being case-insensitive, that is not a bug.  Case-insensitivity does not apply to special documented targets like .PHONY etc.

I'm marking this as "Enhancement" right now but I'm inclined to close it as "Not a Bug".  Comments requested.

Paul D. Smith <psmith>
Project Administrator
Wed 08 Oct 2008 05:50:36 PM UTC, original submission:  

If make is compiled with --enable-case-insensitive-file-system, then prony targets are treated case insensitively.
(But this is not consistently applied to all targets, e.g. ".PHony" does not have any special side effects.)

I think that phony targets should always be case sensitive.

(This issue was noticed when a make compiled with --enable-case-insensitive-file-system confused the phony target "install" with the rules for file "INSTALL".)

Stepan Kasal <kasal>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by psmith (Posted a comment)
  • -email is unavailable- added by kasal (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2009-06-02 psmith StatusNone Not A Bug
        Open/ClosedOpen Closed
    2009-06-01 psmith Item GroupBug Enhancement

    Back to the top


    Powered by Savane 3.9