bugXBoard - Bugs: bug #22853, man page should not refer to...

 
 

bug #22853: man page should not refer to .Xdefaults

Submitter:  Tim Mann <mann>
Submitted:  Sun 06 Apr 2008 04:33:59 PM UTC
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  Fixed
Assigned to:  apersaud Open/Closed:  Closed
Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Sun 01 Mar 2009 04:25:13 AM UTC, comment #5: 

changed all .Xdefaults references to .Xresources in CVS

closing this bug.

Arun Persaud <apersaud>
Project Administrator
Tue 08 Apr 2008 04:52:03 PM UTC, comment #4: 

Oops, sorry, I failed to read your initial bug report in full.  I've addressed it back in the gentoo bugzilla where the details are.  See https://bugs.gentoo.org/show_bug.cgi?id=216493 comment #5.

Again, the only bug is that the man page should not mention .Xdefaults.

Tim Mann <mann>
Project Administrator
Tue 08 Apr 2008 11:10:42 AM UTC, comment #3: 

Sorry for not being clear enough. I did not complain about a man page. And I have already put the necessary values in the right files. I tried both .Xresources, ~/XBoard and the other possible values.
The issue is that from neither X11 resource file xboard read in my 2 defined config values.
Please have a look at the original bug report.

Toralf Förster <toralf>
Mon 07 Apr 2008 06:15:04 PM UTC, comment #2: 

Your "clarification" is wrong.  xboard reads resources in the standard way for Xt apps, by calling XtAppInitialize.  This gets the resources that are stored in the X server itself (the ones you can see by typing xrdb -query; see "man xrdb" for details) and those that are in the file ~/XBoard.

When you start X, "startx" or whatever desktop environment you use reads some default resources from a file and sets them into the X server using xrdb.  The standard name of this file was .Xdefaults many years ago, but now it's .Xresources.  xboard, like other apps, sees these resources only because of that initialization.

So, the only bug here is that xboard should not be referring to the obsolete file name ".Xdefaults" in its man page.

Tim Mann <mann>
Project Administrator
Mon 07 Apr 2008 08:07:18 AM UTC, comment #1: 

The clarify it, the real problem isn't the file name. Instead xboard doesn't read the content of an X11 resource file correctly.

Toralf Förster <toralf>
Sun 06 Apr 2008 04:33:59 PM UTC, original submission:  

I'm told that .Xdefaults was deprecated several decades ago in favor of .Xresources.  It seems that recently X installations have stopped looking at .Xdefaults.  The xboard man page still says to put resources in .Xdefaults, though.  This should be changed to say that the resources can be put into ~/.Xresources or ~/XBoard.

See gentoo bugzilla https://bugs.gentoo.org/show_bug.cgi?id=216493

Tim Mann <mann>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by apersaud (Posted a comment)
  • -email is unavailable- added by toralf (Posted a comment)
  • -email is unavailable- added by mann (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2009-03-01 apersaud StatusNone Fixed
        Assigned toNone apersaud
        Open/ClosedOpen Closed
    2008-08-11 mann Attached File#16267 Removed
    2008-08-10 None Attached File- Added bg.jpg, #16267

    Back to the top


    Powered by Savane 3.9