bugPSPP - Bugs: bug #21329, config.charset does not support...

 
 

bug #21329: config.charset does not support OpenBSD

Submitted by:  Ben Pfaff <blp>
Submitted on:  Fri 12 Oct 2007 12:24:12 AM UTC  
 
Category:  Compilation/Portability Severity:  5 - Average
Status:  Fixed Assigned to:  None
Open/Closed:  Closed Release:  Before 0.6.0
Effort:  0.00

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 14 Nov 2007 02:43:30 PM UTC, comment #11: 

Bruno Haible committed a fix to gnulib:
http://permalink.gmane.org/gmane.comp.gnu.utils.bugs/15206
so I am closing this bug.

Ben Pfaff <blp>
Project Administrator
Tue 13 Nov 2007 06:29:55 PM UTC, comment #10: 

>I've reported this problem to the maintainer responsible:


Some progress on this front:

http://permalink.gmane.org/gmane.comp.gnu.utils.bugs/15195
http://permalink.gmane.org/gmane.comp.gnu.utils.bugs/15196

I am hopeful that this bug can be resolved upstream within a few days.

Ben Pfaff <blp>
Project Administrator
Sat 10 Nov 2007 09:28:44 PM UTC, comment #9: 

>...compression.sh, which fails with this diff:


This one had a trivial fix: add "-b" to the diff command.  I tested it out on math.gcsu.edu and checked in the fix.

Ben Pfaff <blp>
Project Administrator
Sat 10 Nov 2007 08:18:44 PM UTC, comment #8: 

This turns out to actually be a bug in gl/config.charset that we get via gnulib.  This script is supposed to print a list of aliases from system charset names to the canonical GNU list of charset names.  But it doesn't support OpenBSD.  It can be fixed by changing the line that reads
    netbsd*)
to read
    netbsd* | openbsd*)
then running make and either installing the generated charset.alias into $(LIBDIR)--generally /usr/lib or /usr/local/lib--or setting CHARSETALIASDIR to the directory containing charset.alias when running "make check", like so:
    make check CHARSETALIASDIR=/directory/to/charset.alias

I've reported this problem to the maintainer responsible:
http://permalink.gmane.org/gmane.comp.gnu.utils.bugs/15187

Ben Pfaff <blp>
Project Administrator
Mon 15 Oct 2007 05:36:32 PM UTC, comment #7: 

All of them except filter.sh (bug #21330) and compression.sh, which fails with this diff:

< 0000000  000001                                                
---

> 0000000 000001

check compression byte
FAILED
FAIL: tests/bugs/compression.sh

Jason H Stover <jstover>
Project Member
Mon 15 Oct 2007 04:00:21 PM UTC, comment #6: 

>The patch caused the tests to pass...


Wow, all of them?  I will have to figure out why, in a couple of cases, then.  I expected that it would only affect some of them.

Ben Pfaff <blp>
Project Administrator
Mon 15 Oct 2007 03:00:56 PM UTC, comment #5: 

The patch caused the tests to pass, so the failures are caused by the UTF error messages.

Jason H Stover <jstover>
Project Member
Mon 15 Oct 2007 04:52:20 AM UTC, comment #4: 

I think that John is right, but there are a few confusing bits in the source tree and the tests here.  Jason, are you willing to try an experiment?  Apply the patch that I am attaching, which simply deletes the lines of code that generate that message.  Then we will see what effect it has on the test results.  Probably, most of those tests will now be fixed, but some will remain.  I want to know what changes.

(file #14144)

Ben Pfaff <blp>
Project Administrator
Sat 13 Oct 2007 05:09:08 AM UTC, comment #3: 

Those messages are the first thing to fix anyhow, and then we'll see what's left.  I'll see what I can do.

Ben Pfaff <blp>
Project Administrator
Sat 13 Oct 2007 12:02:02 AM UTC, comment #2: 

I think you're right.

These warnings should be (relatively) harmless. But some of the tests compare the stderr stream, notably Ben's debug features.

Maybe the DEBUG messages could go to a seperate stream, controlled by a flag?

John Darrington <jmd>
Project Administrator
Fri 12 Oct 2007 08:15:47 PM UTC, comment #1: 

At least two of these tests fail because the BSD box is printing
this message:

Warning: cannot create a convertor for "646" to "UTF-8": Invalid argument
Warning: cannot create a convertor for "646" to "646": Invalid argument

If I fix this, I have a hunch all the tests will pass. So which program is griping in those messages?

Jason H Stover <jstover>
Project Member
Fri 12 Oct 2007 12:24:12 AM UTC, original submission:  

Jason Stover reports that the following tests fail on OpenBSD:

compression.sh
overwrite-input-file.sh
signals.sh
moments.sh
expressions.sh
epoch.sh

Ben Pfaff <blp>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #14144:  i18n-test.pspp added by blp (493B - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jmd (Posted a comment)
  • -email is unavailable- added by jstover (Posted a comment)
  • -email is unavailable- added by blp (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2007-11-14 blp StatusWorks For Me => Fixed
        Open/ClosedOpen => Closed
    2007-11-10 blp StatusIn Progress => Works For Me
        SummaryTests fail on OpenBSD => config.charset does not support OpenBSD
    2007-10-15 blp Attached File- => Added i18n-test.pspp, #14144
    2007-10-13 blp StatusNone => In Progress
    2007-10-12 blp ReleaseNone => Before 0.6.0

    Back to the top


    Powered by Savane 3.5