bugmake - Bugs: bug #19183, double-colon pattern rules

 
 

bug #19183: double-colon pattern rules

Submitted by:  David Bateman <dbateman>
Submitted on:  Fri 02 Mar 2007 11:46:44 AM UTC  
 
Severity:  3 - Normal Item Group:  Bug
Status:  Not A Bug Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  3.80 Operating System:  Any
Fixed Release:  None Triage Status:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 02 Mar 2007 02:04:10 PM UTC, comment #1: 

This is not a bug.  Double colon implicit rules have a different meaning than double-colon explicit rules.  See the section "Match-Anything Pattern Rules" in the GNU make manual.

Paul D. Smith <psmith>
Project Administrator
Fri 02 Mar 2007 11:46:44 AM UTC, original submission:  

Consider the makefile

pat=$(filter-out %/,$(subst /,/ ,$@))

target/%::
@echo "$(pat) 1"

target/%::
@echo "$(pat) 2"

target::
@echo "test 1"

target::
@echo "test 2"

I'd hoped that "make target/test" would run the two double-colon pattern rules, like "make target" does. However, this appears not to be the case. If this is a bug or not is definitely a matter of opinion, but having this feature would certainly be useful to me..

Regards
D.

David Bateman <dbateman>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by psmith (Posted a comment)
  • -email is unavailable- added by dbateman (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2007-03-02 psmith StatusNone => Not A Bug
        Open/ClosedOpen => Closed
    2007-03-02 dbateman Carbon-Copy- => Added david.bateman@motorola.com

    Back to the top


    Powered by Savane 3.5