bugmake - Bugs: bug #19035, Make recompiles source files...

 
 

bug #19035: Make recompiles source files eventhough the files are not modified

Submitted by:  yasothamani <ymani>
Submitted on:  Mon 12 Feb 2007 07:32:31 AM UTC  
 
Severity:  3 - Normal Item Group:  Build/Install
Status:  Not A Bug Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  3.81 Operating System:  POSIX-Based
Fixed Release:  None Triage Status:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 13 Feb 2007 01:54:43 PM UTC, comment #3: 

Comment #2 suits for me, and now the make is running ok.

Earlier what I done was copied the source file into AIX box and then given the make.

Today I mounted the source file from our server and then tried the make, it's working fine.

I'm sorry I can't give the sample of the makefile as I don't have that right.

Thanks for your suggestion.

yasothamani <ymani>
Mon 12 Feb 2007 04:19:40 PM UTC, comment #2: 

Also, if your source was last written on machine A and you're now trying to compile those files on machine B and machine B's clock is so far behind machine A's that the source files' timestamps still appear to be the future, then you'd see this behavior.  You would probably also see warnings about clock skew - so when you post your small example of a makefile, please post the output you see too, so we can eliminate that.

Martin Dorey <mdorey>
Mon 12 Feb 2007 12:24:01 PM UTC, comment #1: 

Sorry, but there's nothing we can do unless you provide more details, such as a small example of a makefile that does not work properly for you.

Note that Solaris and HP contain SystemV make; GNU make is not intended to be a 100% compatible replacement for SystemV make.  GNU make is an implementation of POSIX-standard make, with many (MANY) extensions.  Just because your makefile works with Solaris and HP make does not automatically mean it will work with GNU make--it all depends on what SystemV special features you may be using, etc.

Paul D. Smith <psmith>
Project Administrator
Mon 12 Feb 2007 07:32:31 AM UTC, original submission:  

I downloaded the make 3.81 source and compiled in the AIX 5.3 machine as per the steps in the INSTALL file.

The steps I used was
1. ./configure --prefix=PREFIX
2. make
3. make install

After these process i pointed to the builded make.

The problem now is that make recompiles the source completely even though the files are not modified. Makefile which I'm using is compiling fine in SOLARIS and HP.

Please help me in this to get rid of this problem.

yasothamani <ymani>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mdorey (Posted a comment)
  • -email is unavailable- added by psmith (Posted a comment)
  • -email is unavailable- added by ymani (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2007-05-01 psmith StatusNone => Not A Bug
        Open/ClosedOpen => Closed
    2007-02-12 ymani Carbon-Copy- => Added ymani

    Back to the top


    Powered by Savane 3.5