bugphpGroupWare - Bugs: bug #15916, Again trouble handling LDAP...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #15916: Again trouble handling LDAP account...

Submitted by:  Marco Gaiarin <gaio>
Submitted on:  Mon 27 Feb 2006 02:54:02 PM UTC  
 
Item Group: 0.9.16.010Category: API - Admin
Severity: 3 - NormalPriority: 5 - Normal
Status: Wont FixPrivacy: Public
Assigned to: Caeies <Caeies>Open/Closed: Open
Component Version: SVNOperating System: GNU/Linux - Debian
Reproducibility: Every TimePlanned Release: None
Fixed Release: 

Wed 08 Mar 2006 05:24:14 PM UTC, comment #2:

I'm only speaking about membership, not the full ACL.

Apart that it is not clear to me because simply group membership are taken from LDAP instead from ACL (i suspect hystorical reason, too code to change in too many places ;), i propose a very simple task:

At every user login into phpgw, all the group membership of the user are reset (delete from phpgw_acl where acl_appname='phpgw_group' and acl_account=1000) and reinserted using as source the LDAP membership data.

Clearly this is a brute-force approach, a beter approach would be to verify every membership and add/remove only the needed one.

Clearly this could be achived by a global/config switch, not enabled by default. ;)

AFAI've understood phpgw, this could not pose any problem at all to phpgw, or at least not pose any problem more hard that modifing membership in Administration page by hand.

In this way i will be able to do user management with every interface i like.
Hope now it is clear, and hope also that i've not missed too many ``details''... O;-)))

Marco Gaiarin <gaio>
Mon 06 Mar 2006 01:11:32 PM UTC, comment #1:

Hi Marco,

Group membership are handled by ACL, and exported to LDAP.
This is only a way for external apps to get these infos. Of course if your tools broke them ... well that's not our fault ...

So using external tools to add people into groups is not an option for phpgw, since we depends on ACL (in SQL) and not LDAP. This could be added in future release of phpgw, but not in .16 I'm afraid.

Regards,

Caeies

Caeies <Caeies>
Project AdministratorIn charge of this item.
Mon 27 Feb 2006 02:54:02 PM UTC, original submission:

Another little troublen handling accounts and group in LDAP.
I've tested it also in my new installation.

Now create my account using smbldap-tools, then i use a LDAP browser (GNOME GQ) to add PHPGW ObjectClass and data.

But in this way membership are not preseved, and i've to enter phpgw as administrator, edit user data and reset group membership.

This is a real pain, because:

+ this force me to use phpgw to handle membership
+ if for some reason i use some other tool to handle membership, it is easy to override/get lost this membership working on phpgw.

For me an ideal approach will be simply: at every login, ldap membership data have to be copied into phpgw_acl array as phpgw membership; to me this seems a simple and effective approach.

Marco Gaiarin <gaio>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

Please enter the title of George Orwell's famous dystopian book (it's a date):

 

 

Follow 2 latest changes.

Date Changed By Updated Field Previous Value => Replaced By
Mon 06 Mar 2006 01:11:32 PM UTCCaeiesStatusNone=>Wont Fix
  Assigned toNone=>Caeies

Back to the top


Powered by Savane 3.1-cleanup1