bugGNU Screen - Bugs: bug #14930, Mouse actions not passed through...

 
 

bug #14930: Mouse actions not passed through screen

Submitted by:  None
Submitted on:  Tue 08 Nov 2005 01:03:47 PM UTC  
Votes:  120  
 
Category:  None Severity:  3 - Normal
Priority:  5 - Normal Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Closed Release:  None
Fixed Release:  None Planned Release:  None
Work Required:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Fri 15 Aug 2008 07:37:06 PM UTC, comment #7: 

bug 24075 tracks requested improvements to screen's ability to detect mouse support in a terminal. Note that they still wouldn't cause vim to work without the .vimrc changes ("set ttymouse=xterm") mentioned below, since vim itself looks explicitly at the value of $TERM, rather than checking for the kM termcap.

Micah Cowan <micahcowan>
  Spam posted by anonymous
Fri 13 Jun 2008 08:06:02 AM UTC, comment #6: 

Closing out this bug as it contains a couple of appropriate suggestions for how to address the problem.

Micah Cowan <micahcowan>
  Spam posted by anonymous
  Spam posted by anonymous
  Spam posted by anonymous
  Spam posted by anonymous
  Spam posted by anonymous
  Spam posted by anonymous
  Spam posted by anonymous
  Spam posted by anonymous
  Spam posted by anonymous
  Spam posted by anonymous
Mon 21 Apr 2008 08:23:24 PM UTC, comment #5: 

I've found that this problem can be fixed by adding a line like this to your .screenrc:

termcapinfo linux|xterm|rxvt|xterm-color ti@:te@:XT

The XT part tells screen that the 'real' terminal understands XTerm specific stuff like mouse reporting.

This works for me with PuTTY on Windows connected to Ubuntu GNU/Linux using the "linux" style terminal.

Note that you can override the application's use of the mouse by holding down shift, assuming the appropriate PuTTY option is checked.  This is useful when e.g. copying some text out of a console Emacs session into a Window application.

Anonymous
  Spam posted by anonymous
Wed 24 Oct 2007 10:42:56 PM UTC, comment #4: 

:set ttymouse=xterm2 gets mouse events working with vim with a screen session

Anonymous
Sat 21 Jul 2007 07:02:43 PM UTC, comment #3: 

I have a similar issue with vim, screen, and the mouse.

I can position the cursor using the mouse in vim but not when vim is in a screen session.

Anonymous
Thu 10 May 2007 12:03:08 PM UTC, comment #2: 

I can confirm this.
Running emacs -nw in a screen session and enabling "xterm-mouse-mode" in emacs results in the following error message;
"<mouse-1> not defined" when trying to use the mouse. The mouse works fine in this emacs mode when not inside a screen session.

Nicholas Brown <nickbrown>
Tue 08 Nov 2005 01:06:47 PM UTC, comment #1: 

Bug submitted by johnpye

John Pye <johnpye>
Tue 08 Nov 2005 01:03:47 PM UTC, original submission:  

Hi there,

I tried to use Midnight Commander through Screen, and it worked nicely but I couldn't use my mouse. I checked the man page and it appears that Screen has some kind of support for the mouse, since various escape sequences are listed there, but it didn't work for me.

Using gnome-terminal on FC3 to access screen installed remotely on FC4, screen version 4.0.2.

JP

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by micahcowan (Posted a comment)
  • -email is unavailable- added by analogue73 (Voted in favor of this item)
  • -email is unavailable- added by nickbrown (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 120 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2008-06-13 micahcowan StatusNone => Invalid
        Open/ClosedOpen => Closed
    2008-01-11 analogue73 Carbon-Copy- => Added analogue73
    2007-05-10 nickbrown Carbon-Copy- => Added nickbrown

    Back to the top


    Powered by Savane 3.5