helpSavannah Administration - Support: sr #109536, Trouble Using Savannah Bug Tracker

 
 

sr #109536: Trouble Using Savannah Bug Tracker

Submitted by:  Armin Müller <arm_in>
Submitted on:  Tue 24 Jul 2018 05:25:22 PM UTC  
 
Category:  Savannah trackers - bugs, tasks, etc. Priority:  5 - Normal
Severity:  3 - Normal Status:  Need Info
Assigned to:  Ineiev <ineiev> Operating System:  None
Open/Closed:  Open

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 01 Aug 2018 01:06:31 PM UTC, comment #6:

Still doesn't reproduce for me, with URL

Ineiev <ineiev>
Site AdministratorIn charge of this item.
Tue 31 Jul 2018 09:25:21 AM UTC, comment #5:

When I read the other two cases, it seems that the settings are important:

Default for Octave:

Open/Closed = "Open"
Additional constraint = "deactivated"

Failure Case for Octave:

Open/Closed = "Any"
Additional constraint = "activated" <= this one is relevant
Any modified since = "[any date]"

The setting "Additional constraint = activated" will lead to the bug.

Armin Müller <arm_in>
Sat 28 Jul 2018 12:35:30 PM UTC, comment #4:

...and to sr #109187.

Ineiev <ineiev>
Site AdministratorIn charge of this item.
Sat 28 Jul 2018 12:33:56 PM UTC, comment #3:

Looks similar to sr #107979.

Ineiev <ineiev>
Site AdministratorIn charge of this item.
Thu 26 Jul 2018 09:26:31 PM UTC, comment #2:

I just tried to clear all cookies in connection with "gnu" and "savannah". However, the effect still does happen.

Armin Müller <arm_in>
Thu 26 Jul 2018 10:24:02 AM UTC, comment #1:

I did encounter such errors, but I can't reproduce this one. Does it still happen after you clear your Savannah cookies?

Ineiev <ineiev>
Site AdministratorIn charge of this item.
Tue 24 Jul 2018 05:25:22 PM UTC, original submission:

For some reason, and for some weeks now, the bug tracker in Octave is broken when I'm using it. An SQL error is appearing when browsing the bug list.

https://savannah.gnu.org/bugs/?group=octave

Example:

"Bugs => Browse" gives

db_query: SQL query error Unknown column 'bugs.bug_id' in 'on clause' in [SELECT count(DISTINCT bugs.bug_id) AS count FROM bugs ,user user_assigned_to LEFT JOIN bugs_history ON ((bugs_history.bug_id = bugs.bug_id ) AND (bugs_history.date >= 0) AND (bugs_history.field_name = NULL)) WHERE bugs.group_id='1925' AND (bugs.spamscore < '5' OR submitted_by='94238') AND user_assigned_to.user_id=bugs.assigned_to AND bugs_history.bug_id IS NULL]

"Bugs => Reset to open"

... then gives results as expected, again. I have to restore my settings manually, however.

Posted before as Octave bug #54355

Armin Müller <arm_in>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ineiev (Posted a comment)
  • -email is unavailable- added by arm_in (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-07-26 ineiev StatusNone => Need Info
        Assigned toNone => ineiev

    Back to the top


    Powered by Savane 3.3