bugGNU roff - Bugs: bug #64404, [bjarnigroff] Makefile.am:...

 
 

bug #64404: [bjarnigroff] Makefile.am: MOSTLYCLEANDIRS has no content

Submitter:  Bjarni Ingi Gislason <bjarniig>
Submitted:  Mon 10 Jul 2023 03:17:54 PM UTC
   
 
Category:  General Severity:  2 - Minor
Item Group:  Lint Status:  Invalid
Privacy:  Public Assigned to:  gbranden
Open/Closed:  Closed Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Mon 10 Jul 2023 03:29:51 PM UTC, comment #2: 

On second thought I'm closing this.

It's pretty obvious the diagnostic you're reporting is not against the groff that is publicly available.  Just compare line numbers with the "Makefile.am" from groff Git HEAD.

If you want assistance from others in developing your private fork of groff, the groff @ gnu mailing lists is the place to ask for it.  The Savannah bug tracker is here to support GNU roff, not your variation of it.


...
   500  noinst_LIBRARIES =
   501  BUILT_SOURCES =
   502  CLEANFILES =
   503  # gnulib asks to include this file
   504  EXTRA_DIST = gnulib_m4/gnulib-cache.m4
   505  FONTFILES =
   506  PREFIXMAN1 =
   507  man1_MANS =
   508  man5_MANS =
   509  man7_MANS =
   510
   511  # for lex/yacc
   512  AM_YFLAGS = -d -v
   513
   514  SUFFIXES =
   515
   516  # tests launched by make check
   517  check_SCRIPTS =
   518  check_PROGRAMS =
   519  TESTS =
   520  XFAIL_TESTS =
   521  AM_TESTS_ENVIRONMENT = \
   522    abs_top_srcdir=$(abs_top_srcdir) \
   523    abs_top_builddir=$(abs_top_builddir) \
   524    export abs_top_srcdir abs_top_builddir;
   525
   526  # We use Automake's Uniform Naming Scheme.
   527  #
   528  # prefixexecbin_PROGRAMS is the list of programs that may have a
   529  # NAMEPREFIX if an existing non-GNU troff system was detected.
   530  #
   531  # This is done by the m4 macro GROFF_G that checks for the presence of
   532  # GNU Troff built-in \n[.g] macro. If a Unix Troff binary was
   533  # detected, the following programs and scripts names will have a 'g'
   534  # prefix: chem, tbl, eqn, neqn, pic, soelim, grn, refer, lookbib,
   535  # troff, nroff. Also, PROG_PREFIX will be set to 'g' in the generated
   536  # header defs.h so that these programs could be called correctly.
   537  #
   538  # prefixexecbindir is used to temporary install these programs. They
   539  # are then moved to bindir during the install-exec-hook.  Same thing
   540  # for the scripts.
   541  NAMEPREFIX=$(g)
   542  prefixexecbin_PROGRAMS =
   543  prefixexecbin_SCRIPTS =
   544  if USEPROGRAMPREFIX
   545  # We use datadir because the uninstall rule for the PROGRAMS attempts
   546  # to cd into prefixexecbindir, and thus if prefixexecbindir is removed
   547  # two consecutive uninstalls would fail
   548  prefixexecbindir = $(datadir)
   549  else
   550  prefixexecbindir = $(bindir)
   551  endif
   552
   553  # Path to binaries and flags used by contribs and doc to generated doc.
   554  # These may be overridden if cross-compiling.
   555  GROFFBIN = $(abs_top_builddir)/groff
   556  GROFF_BIN_PATH = $(abs_top_builddir)
   557  PDFMOMBIN = $(abs_top_builddir)/pdfmom
   558  # Search for macro files and device/font description directories in
   559  # source _and_ build trees; some of each are generated.
   560  FFLAG=-F$(abs_top_builddir)/font -F$(abs_top_srcdir)/font
   561  MFLAG=-M$(abs_top_builddir)/tmac -M$(abs_top_srcdir)/tmac
   562
   563  if !MAKE_DEFINES_RM
   564  RM=rm -f
   565  endif
   566
   567  # 'VERSION' is generated by gnulib script git-version-gen, using the
   568  # command 'git describe':
   569  #
   570  # - From a git repository: if the current commit corresponds to a
   571  #   tag, then 'VERSION' is simply the tag (e.g. 1.22.3).  Otherwise
   572  #   'VERSION' has the following format:
   573  #     <tag>-<nb_commits>-<commit>
   574  #
   575  #   With:
   576  #     . tag: the most recent tag reachable from the current commit
   577  #     . nb_commits: number of commits between the most recent tag and
   578  #       the current commit.
   579  #     . current commit, abbreviated.
   580  #   For example: 1.22.3.real.434-5aafd
   581  #   The version is stored in .version.
   582  #
   583  # - From a tarball, the version is taken from .tarball-version
   584  #
   585  # REVISION is the full revision given by git-version-gen, which can
   586  # have non-alphanumeric symbols.
   587  #
   588  # Also see configure.ac for the related SHORT_VERSION macro.
   589
   590  MAJOR_VERSION = `echo $(VERSION) | cut -d . -f 1`
   591  MINOR_VERSION = `echo $(VERSION) | cut -d . -f 2`
   592  REVISION      = `echo $(VERSION) | cut -d . -f 3`
   593
   594  # Non-recursive makefile system. See Automake manual '7.3 An
   595  # Alternative Approach to Subdirectories'. We use a single Makefile.am
   596  # that includes other .am files, rather than using SUBDIRS.  Note that
   597  # relative paths in the following .am files are relative to the top
   598  # source directory.
   599
   600  # Initialize Automake variables we haven't already handled; see section
   601  # "3.8 Modifying the build rules of a Gnulib import directory" in the
   602  # Gnulib manual.
   603  AUTOMAKE_OPTIONS =
   604  SUBDIRS =
   605  noinst_HEADERS =
   606  noinst_LTLIBRARIES =
   607  pkgdata_DATA =
   608  MOSTLYCLEANDIRS =
   609  AM_CFLAGS =
   610
   611  include $(top_srcdir)/lib/gnulib.mk
   612  include $(top_srcdir)/arch/mingw/mingw.am
   613  include $(top_srcdir)/arch/misc/misc.am
   614  include $(top_srcdir)/contrib/chem/chem.am
   615  include $(top_srcdir)/contrib/eqn2graph/eqn2graph.am
   616  include $(top_srcdir)/contrib/gdiffmk/gdiffmk.am
   617  include $(top_srcdir)/contrib/glilypond/glilypond.am
   618  include $(top_srcdir)/contrib/gperl/gperl.am
   619  include $(top_srcdir)/contrib/gpinyin/gpinyin.am
   620  include $(top_srcdir)/contrib/grap2graph/grap2graph.am
   621  include $(top_srcdir)/contrib/hdtbl/hdtbl.am
   622  include $(top_srcdir)/contrib/mm/mm.am
   623  include $(top_srcdir)/contrib/mom/mom.am
   624  include $(top_srcdir)/contrib/pdfmark/pdfmark.am
   625  include $(top_srcdir)/contrib/pic2graph/pic2graph.am
   626  include $(top_srcdir)/contrib/rfc1345/rfc1345.am
   627  include $(top_srcdir)/contrib/sboxes/sboxes.am
   628  include $(top_srcdir)/doc/doc.am
...


G. Branden Robinson <gbranden>
Group administrator
Mon 10 Jul 2023 03:25:24 PM UTC, comment #1: 

I can't reproduce this.

See the typescript attached to bug #64403, where this diagnostic does not appear.

I need a recipe to reproduce this problem with the stock groff master branch, or I will have to close this ticket.

G. Branden Robinson <gbranden>
Group administrator
Mon 10 Jul 2023 03:17:54 PM UTC, original submission:  

Subject: Makefile.am: MOSTLYCLEANDIRS has no content

  Output from "bootstrap":

Makefile.am:618: warning: MOSTLYCLEANDIRS multiply defined in condition TRUE ...
Makefile.am:506: ... 'MOSTLYCLEANDIRS' previously defined here

  In Makefile.am:

  In line 506:

MOSTLYCLEANDIRS =

  In line 618:

MOSTLYCLEANDIRS =

  This variable is never used.

Bjarni Ingi Gislason <bjarniig>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by gbranden (Posted a comment)
  • -email is unavailable- added by bjarniig (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2023-09-23 gbranden SummaryMakefile.am: MOSTLYCLEANDIRS has no content [bjarnigroff] Makefile.am: MOSTLYCLEANDIRS has no content
    2023-07-10 gbranden StatusUnreproducible Invalid
        Open/ClosedOpen Closed
    2023-07-10 gbranden CategoryCore General
        Severity3 - Normal 2 - Minor
        Item GroupBuild/Installation Lint
        StatusNone Unreproducible
        Assigned toNone gbranden

    Back to the top

    Powered by Savane 3.13-3736.
    Corresponding source code