bugmake - Bugs: bug #64288, The flag --no-print-directory...

 
 

bug #64288: The flag --no-print-directory becomes effective too early

Submitter:  Masahiro Yamada <masahiroy>
Submitted:  Fri 09 Jun 2023 08:15:30 AM UTC
   
 
Severity:  3 - Normal Item Group:  None
Status:  Not A Bug Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  None Operating System:  None
Fixed Release:  None Triage Status:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Fri 09 Jun 2023 12:39:02 PM UTC, comment #1: 

This behavior is intentional: setting MAKEFLAGS as a make variable assignment modifies the behavior of the currently-running make.  If users want to disable printing directories for the current makefile they can do so by setting the MAKEFLAGS variable.

If you don't want to disable this setting for this instance of make, don't add it to MAKEFLAGS.

If you want to leave print-directories for this makefile but have it unset for children of this makefile, then you can add the flag to the invocation of the child makes.

Paul D. Smith <psmith>
Group administrator
Fri 09 Jun 2023 08:15:30 AM UTC, original submission:  

Since 8f9e7722ff0f80d9f6ae9aba350ae02c3c6db878, --no-print-directory flag gets effective too early.

[Sample Code]

$ cat Makefile
all: ; $(MAKE) -C sub

$ cat sub/Makefile
MAKEFLAGS += --no-print-directory
all: ; @echo hello

[Test Result]

Prior to commit 8f9e7722ff0f80d9f6ae9aba350ae02c3c6db878,

$ make-4.4
make-4.4 -C sub
make-4.4[1]: Entering directory '/tmp/sub'
hello
make-4.4[1]: Leaving directory '/tmp/sub'

Since commit 8f9e7722ff0f80d9f6ae9aba350ae02c3c6db878,

$ make-4.4.1
make-4.4.1 -C sub
hello


I believe "--no-print-directory" in sub/Makefile should not suppress the "Entering directory to sub".

Masahiro Yamada <masahiroy>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by psmith (Posted a comment)
  • -email is unavailable- added by masahiroy (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2023-06-09 psmith StatusNone Not A Bug
        Open/ClosedOpen Closed

    Back to the top

    Powered by Savane 3.13-4448.
    Corresponding source code