bugGNU nano - Bugs: bug #63313, [Wish] extend soft-wrap with a...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #63313: [Wish] extend soft-wrap with a number parameter similar to the --fill option

Submitter:  Sergey Torokhov <band_a_prend>
Submitted:  Thu 03 Nov 2022 09:44:51 PM UTC
 
Severity:  1 - Wish Status:  Wont Fix
Assigned to:  None Open/Closed:  Open

Fri 18 Nov 2022 03:57:24 PM UTC, comment #3: 

I'm glad that the patch serves your need.  (But as said, it will not become part of default nano.)

Benno Schulenberg <bens>
Project Administrator
Thu 10 Nov 2022 06:17:43 PM UTC, comment #2: 

Great thanks for the patch!
Sorry for long delay of feedback I hoped initially to apply patch before answer and finally reach my PC to test it.
On Gentoo Linux (source based distributive) there is no problem to do it before package build and install.

I used the following .config/nano/nanorc:

set constantshow
set multibuffer
set linenumbers
set guidestripe 72
set stripecolor normal,yellow
set tabstospaces
set tabsize 4
set autoindent
set smarthome
set atblanks
set fill 72
set minibar

The screenshot of nano-6.4 after enabling of soft-wrapping without (left panel) and with patch (right panel) is attached
(nano-6.4_before_and_after_fill_patch.png).

The each window is half of my 1680х1050 display.

Sergey Torokhov <band_a_prend>
Sun 06 Nov 2022 03:31:35 PM UTC, comment #1: 

I don't like the idea of adding another option.  But... I can understand the desire to softwrap at an earlier point than the right edge of the terminal: my VTs (that I seldom use) are 180 columns, which would give lines that are too long to read comfortably.

Attached is a patch for you to try out: it uses the value of --fill (when positive and smaller than the width of the terminal) to set the width for softwrapping.  The idea is that people that use softwrapping probably don't use hardwrapping and thus do not use --fill or 'set fill'.

(Personally I do use 'set fill' even though I do not use 'set breaklonglines', because there is one file that I want to justify now and then.  So I do not want to merge this patch into nano, but you could use it as private mod.)

(file #53934)

Benno Schulenberg <bens>
Project Administrator
Thu 03 Nov 2022 09:44:51 PM UTC, original submission:  

Is it possible to add an option with possibility of setting up the 'number' parameter for soft-wrap similar of that for 'set fill' option? Maybe additional option is  reasonable, e.g. 'set softfill' or something else.

This could be usefull for user to be able to restrict soft-wrapping within max column limit or guideline position is taking into account by 'set atblanks' option if needed. I.e. if visible area is greater then guildeline column position then option forces soft-wrapping before guideline or specified column number.

This could make text more readable on wide screens or just within graphical terminal emulators.

Sergey Torokhov <band_a_prend>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bens (Updated the item)
  • -email is unavailable- added by band_a_prend (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2022-11-18 bens StatusNone Wont Fix
    2022-11-10 band_a_prend Attached File- Added nano-6.4_before_and_after_fill_patch.png, #53943
    2022-11-06 bens Attached File- Added use-fill-also-for-softwrapping.patch, #53934
        Severity3 - Normal 1 - Wish
        Summary[Wish] Extend soft-wrap with number parameter similar to set fill option [Wish] extend soft-wrap with a number parameter similar to the --fill option

    Back to the top


    Powered by Savane 3.9