bugGNU nano - Bugs: bug #61317, with --preserve, the Execute menu...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #61317: with --preserve, the Execute menu keeps showing ^S Spell Check

Submitted by:  Benno Schulenberg <bens>
Submitted on:  Sat 09 Oct 2021 09:13:00 AM UTC  
 
Severity:  4 - Important Status:  Fixed
Assigned to:  Benno Schulenberg <bens> Open/Closed:  Open

Sat 09 Oct 2021 11:08:56 AM UTC, comment #2: 

Fixed in git, commit 65d81c60, by conditionalizing the showing of ^S, like is done for the other occurrences of ^S and ^Q.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 09 Oct 2021 11:03:27 AM UTC, comment #1: 

Bug exists since version 5.0.  The offending commit was  cd594b85: 'make five tools accessible through the "Execute Command" menu'.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 09 Oct 2021 09:13:00 AM UTC, original submission:  

To reproduce, run 'src/nano --ignore --preserve' and type: ^T
See that in the help lines it says: "^S Spell Check".
Now type: ^S
Nothing happens.  What's more: nano no longer seems to respond to any keystroke because the ^S stopped all output to the terminal.
Type ^Q and ^X to get out of there.

Expected behavior: when --preserve is active, none of the help lines should show ^S (nor ^Q).

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bens (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-10-11 bens Summarywith --preserve, the Execute menu still shows ^S Spell Check => with --preserve, the Execute menu keeps showing ^S Spell Check
    2021-10-09 bens StatusNone => Fixed

    Back to the top


    Powered by Savane 3.7