bugGNU Screen - Bugs: bug #60092, UTF-8 Crash (Even After Patch)

 
 

bug #60092: UTF-8 Crash (Even After Patch)

Submitted by:  Drew <kneesnap>
Submitted on:  Mon 22 Feb 2021 09:51:34 AM UTC  
 
Category:  Crash/Freeze/Infloop Severity:  3 - Normal
Priority:  5 - Normal Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open Release:  4.8.0
Fixed Release:  None Planned Release:  None
Work Required:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 22 Feb 2021 11:35:55 PM UTC, comment #3: 

Thank you! I didn't realize I needed to do that. It seems the fix works after opening a fresh screen. I'm not super familiar with the internal operation of 'screen'. This issue had been giving me grief for a few days, not because anyone had been intentionally exploiting / abusing it, but because it had happened by accident. I want to thank you and everyone else involved for the quick resolution of this issue.

Drew <kneesnap>
Mon 22 Feb 2021 11:14:16 AM UTC, comment #2: 

Hi Drew,

thanks for the bug report and especially the example. (Hint to others: It's 18 MB big and that might be why Savannah refused to attach it.)

I though can't reproduce a crash on neither Debian 9 Stretch nor on Debian Unstable (both with the patch being applied).

So yes, I suspect that the screen session which crashed was still running a server process from before the update.

To benefit from the patch, all running screen sessions need to be restarted. Just reconnecting does not help, as it crashes at least also the server side. This is probably something we should have put into the DSA message but forgot since it was obvious for us, well, at least for me.

Regards, Axel

Axel Beckert <abe>
Mon 22 Feb 2021 09:57:03 AM UTC, comment #1: 

Here is a link to the file, since I cannot upload it through the bug tracker file upload.
https://drive.google.com/file/d/1zJQnhM7oYqLMh_n-TAbVVFgFvYdu1JO4/view?usp=sharing

All it took to segfault the screen was 'cat segfault.txt' inside of a screen. gdb also points to the same function which was causing the segfault earlier. I'm not ruling out the possibility that I may still be using an older version of screen. If that's the case, then it's confusing why I was able to update screen via apt-get, I'm also unsure where I'd get a proper binary build.

Drew <kneesnap>
Mon 22 Feb 2021 09:51:34 AM UTC, original submission:  

Hello! This is regarding the recent UTF-8 character segfault. I have updated my debian stretch machine as of 5 minutes ago (sudo apt-get upgrade listed screen.), yet screen is still segfaulting for me. However, I had a different set of characters causing this issue. I would upload the file here, but it seems I can't upload files through the web portal. I guess I'll try to send a link?

Drew <kneesnap>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by abe (Posted a comment)
  • -email is unavailable- added by kneesnap (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.6