bugGNU Screen - Bugs: bug #58256, Error when swich between screens,...

 
 

bug #58256: Error when swich between screens, parallel typing

Submitted by:  Tuan Le <tuanld>
Submitted on:  Mon 27 Apr 2020 08:38:48 AM UTC  
 
Category:  Program Logic Severity:  3 - Normal
Priority:  5 - Normal Status:  Invalid
Privacy:  Public Assigned to:  Alexander Naumov <anaumov>
Open/Closed:  Closed Release:  4.8.0
Fixed Release:  None Planned Release:  None
Work Required:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Tue 28 Apr 2020 04:53:53 PM UTC, comment #9: 

comment #8:

> ctrl+a " -> show you list of windows, use arrows to navigate.
> It's still duplicate typing.
>


If you have different windows (say "bash 0" and "bash 1") and when you're typing on first one you see the same text on another window?

Ok, can you install git version of screen 4.8.0 and try to reproduce it there?

Alexander Naumov <anaumov>
Project AdministratorIn charge of this item.
Tue 28 Apr 2020 02:36:42 PM UTC, comment #8: 

ctrl+a " -> show you list of windows, use arrows to navigate.
It's still duplicate typing.

Tuan Le <tuanld>
Tue 28 Apr 2020 11:14:30 AM UTC, comment #7: 

comment #6:

> I have this case, I create 5 screen 0,1,2,3,4
> I'm working on screen 4, how can i switch to working on screen 2.
> As current I know, I need to swith to 0,1,2 or 3,2
> How can I direct switch to exact screen.


ctrl+a " -> show you list of windows, use arrows to navigate.
OR
ctrl+a a -> switch to the next window

But again: if you will have, for example, the same two windows on different regions, you will see text you're typing twice.

Alexander Naumov <anaumov>
Project AdministratorIn charge of this item.
Tue 28 Apr 2020 10:42:25 AM UTC, comment #6: 

 I have this case, I create 5 screen 0,1,2,3,4
I'm working on screen 4, how can i switch to working on screen 2.
As current I know, I need to swith to 0,1,2 or 3,2
How can I direct switch to exact screen.

Tuan Le <tuanld>
Tue 28 Apr 2020 09:51:44 AM UTC, comment #5: 

comment #3:

> This is not a bug, this is an expected behaviour.
>
> You just made both regions show the same window – look at the bottom lines, it shows "0 bash" under both regions.


comment #4:

> comment #2:
> > I used Ubuntu 20.04 LTS
> > 1. To install screen. sudo apt install screen -y
> > 2. this is my step:
> >  - Ctrl+a |-> split terminal vertically into regions
> >  - ctrl-a + tab -> move to new screen
> >  - Ctrl+a c -> new window
>
> Here you can see, that the first window (left region) is "bash 0" and second one (right region) is "bash 1".
> Now you can use and enjoy screen :-)
>
> >  - Ctrl+a 0
>
> Now you still have two regions, but both of then show you the same window "bash 0". That's the reason why context is also the same.
> So, I will expect that in this case if you type something you will see the same text on both regions.
>
> > As I understand It will switch to the first screen.
>
> No, if you want to switch to the first region, you have to 'ctrl+a tab' again.
> Ctrl+a <number> is used to switch between windows. As I said, you can see the list of these with ctrl+a ".
>
> > But It doesn't run as expected, My cursor still on the second screen.
> > but when i typing, text display in both of them.
> >
>
> Yep, that's correct. That's not a bug ;-)


comment #3:

> This is not a bug, this is an expected behaviour.
>
> You just made both regions show the same window – look at the bottom lines, it shows "0 bash" under both regions.

Tuan Le <tuanld>
Tue 28 Apr 2020 09:35:32 AM UTC, comment #4: 

comment #2:

> I used Ubuntu 20.04 LTS
> 1. To install screen. sudo apt install screen -y
> 2. this is my step:
>  - Ctrl+a |-> split terminal vertically into regions
>  - ctrl-a + tab -> move to new screen
>  - Ctrl+a c -> new window


Here you can see, that the first window (left region) is "bash 0" and second one (right region) is "bash 1".
Now you can use and enjoy screen :-)

>  - Ctrl+a 0


Now you still have two regions, but both of then show you the same window "bash 0". That's the reason why context is also the same.
So, I will expect that in this case if you type something you will see the same text on both regions.

> As I understand It will switch to the first screen.


No, if you want to switch to the first region, you have to 'ctrl+a tab' again.
Ctrl+a <number> is used to switch between windows. As I said, you can see the list of these with ctrl+a ".

> But It doesn't run as expected, My cursor still on the second screen.
> but when i typing, text display in both of them.
>


Yep, that's correct. That's not a bug ;-)

Alexander Naumov <anaumov>
Project AdministratorIn charge of this item.
Tue 28 Apr 2020 08:53:53 AM UTC, comment #3: 

This is not a bug, this is an expected behaviour.

You just made both regions show the same window – look at the bottom lines, it shows "0 bash" under both regions.

Václav Doležal <vdolezal>
Tue 28 Apr 2020 02:00:49 AM UTC, comment #2: 

I used Ubuntu 20.04 LTS
1. To install screen. sudo apt install screen -y
2. this is my step:
 - Ctrl+a |-> split terminal vertically into regions
 - ctrl-a + tab -> move to new screen
 - Ctrl+a c -> new window
 - Ctrl+a 0 -> As I understand It will switch to the first screen. But It doesn't run as expected, My cursor still on the second screen. but when i typing, text display in both of them.

See my attachmen video

(file #48960)

Tuan Le <tuanld>
Mon 27 Apr 2020 11:24:12 AM UTC, comment #1: 

Hello Tuan,
thanks for report.

Please provide more information (step by step, what you did). Also information about environment (operating system) and how you build/install GNU screen.

Command ctrl-n allows you to switch between windows.

So, for example, if you create the second region (ctrl+a S), switch here (ctrl+a tab), then... you can create the new (second) window (ctrl+a a) OR just use the existing one (ctrl+a n). If you will use existing one, you will see the same output on the two different regions, because they will show you the same window. You can check which window is used on current region by using ctrl+a " comamnd.

Well, that's correct.

Alexander Naumov <anaumov>
Project AdministratorIn charge of this item.
Mon 27 Apr 2020 08:38:48 AM UTC, original submission:  

Version 4.8
When I switch between screen by command ctrl+a n (number of screen).
It is still focus in current screen, when I typing, text is display in 2 screen as file attachment.

Tuan Le <tuanld>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by vdolezal (Posted a comment)
  • -email is unavailable- added by anaumov (Posted a comment)
  • -email is unavailable- added by tuanld (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-04-28 anaumov StatusNeed Info => Invalid
        Assigned toNone => anaumov
        Open/ClosedOpen => Closed
        ReleaseNone => 4.8.0
    2020-04-28 tuanld Attached File- => Added Screencast@from@04-28-2020@08:59:01@AM.webm, #48960
    2020-04-27 anaumov StatusNone => Need Info

    Back to the top


    Powered by Savane 3.6