bugmake - Bugs: bug #57781, make broken on MIPS big-endian if...

 
 

bug #57781: make broken on MIPS big-endian if posix_spawn() is used

Submitted by:  Joshua Kinard <kumba>
Submitted on:  Mon 10 Feb 2020 08:12:50 AM UTC  
 
Severity:  3 - Normal Item Group:  Bug
Status:  Not A Bug Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Component Version:  4.3 Operating System:  POSIX-Based
Fixed Release:  None Triage Status:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 16 Feb 2020 06:04:53 PM UTC, comment #3: 

Thanks all!

Paul D. Smith <psmith>
Project Administrator
Sun 16 Feb 2020 03:41:13 AM UTC, comment #2: 

comment #1:

> <https://sourceware.org/bugzilla/show_bug.cgi?id=25523>


Glibc upstream has marked their bug as fixed, and I can confirm that make-4.3 works on MIPS after rebuilding glibc with the patches.  This bug can be resolved.  Thanks!

Joshua Kinard <kumba>
Mon 10 Feb 2020 10:02:30 AM UTC, comment #1: 
Andreas Schwab <schwab>
Mon 10 Feb 2020 08:12:50 AM UTC, original submission:  

Hi, discovered a bug on a big-endian MIPS setup where posix_spawn(), added in make-4.3, doesn't appear to work right.  When make tries to do operations like executing files, changing directories, calling other programs (e.g., sed), etc, it fails.  Errors range from "operation not permitted" to "cd: <dir>: not a directory", to "permission denied".  Tested on both O32 ABI and N32 ABI.  Cannot test little-endian due to lack of hardware.

I eventually worked out that rebuilding make-4.3 with --disable-posix-spawn results in a working build.  So I am not sure if make's use of posix_spawn is broken, or if the MIPS implementation in glibc is broken.

Joshua Kinard <kumba>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by psmith (Posted a comment)
  • -email is unavailable- added by kumba (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-02-16 psmith StatusNone => Not A Bug
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5