bugGNU nano - Bugs: bug #56461, justifying sometimes misjudges a...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #56461: justifying sometimes misjudges a paragraph

Submitted by:  Benno Schulenberg <bens>
Submitted on:  Sat 08 Jun 2019 01:13:12 PM UTC  
 
Severity:  2 - Minor Status:  Duplicate
Assigned to:  Benno Schulenberg <bens> Open/Closed:  Closed

Sat 08 Jun 2019 03:06:14 PM UTC, comment #3: 

Fixed in git, commit 33fea90b.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 08 Jun 2019 02:43:47 PM UTC, comment #2: 

It turns out that this is in fact a duplicate of bug #56462.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 08 Jun 2019 01:36:43 PM UTC, comment #1: 

Proper reproduction recipe:

  src/nano --ignore --fill=76  +1 NEWS

And type ^J twice.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 08 Jun 2019 01:13:12 PM UTC, original submission:  

To reproduce, run 'src/nano +1 NEWS', and type: ^J ^J.

Note that on the second ^J, the fragment that says "same overflow line" gets rewrapped to the end of the preceding line.  This feels like the right thing to do, as it is the same sentence, but... it is wrong.  It is wrong because the four preceding lines all have the same indentation, and the line with "same overflow line" has a different one, so nano's logic /should/ consider this as a new paragraph -- and versions prior to 4.0 indeed do so.

(It seems to be some uninitialized value, because I get confusing results: sometimes the same version is working right, sometimes not.)

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bens (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-06-11 bens Open/ClosedOpen => Closed
    2019-06-08 bens Open/ClosedClosed => Open
    2019-06-08 bens StatusNone => Duplicate
        Assigned toNone => bens
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.6