bugGNU Wget - Bugs: bug #56105, choco install wget:...

 
 

bug #56105: choco install wget: libwinpthread-1.dll is missing from your computer

Submitted by:  None
Submitted on:  Tue 09 Apr 2019 02:40:39 AM UTC
 
Category:  Build/Install Severity:  3 - Normal
Priority:  5 - Normal Status:  Invalid
Privacy:  Public Assigned to:  None
Originator Name:  Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  trunk
Operating System:  Microsoft Windows Reproducibility:  None
Fixed Release:  None Planned Release:  None
Regression:  None Work Required:  None
Patch Included:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Tue 09 Apr 2019 06:49:45 AM UTC, comment #1: 

Sorry, but we don't directly use threading and don't link with any threading library. It looks like one of the dependencies pull in that library. It's the packager's job to add missing libraries (e.g. as package dependencies).

We are also in no way responsible what eternallybored.org offers. Please report your SSL issue directly there.

Tim Ruehsen <rockdaboot>
Project Administrator
Tue 09 Apr 2019 02:40:39 AM UTC, original submission:  

wget cannot run out of the box when installed with choco install.
Windows 8.1 Pro x64
 - choco install wget

"libwinpthread-1.dll is missing from your computer"

Originally reported at https://github.com/chocolatey/chocolatey-coreteampackages/issues/1260

installing MinGW after does not fix the issue.

Expected: choco install packages dependencies

Running the binary https://eternallybored.org/misc/wget/1.20.3/64/wget.exe does not have the error , but it also shows "Disabling SSL due to encountered errors." when requesting an https URL (see screenshot).

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #46736:  choco_install_wget_libwinpthread_error.png added by None (7KiB - image/png - System error running wget from choco install)
file #46737:  win_wget_https_error.png added by None (4KiB - image/png - System error running wget from choco install)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rockdaboot (Posted a comment)
  •  

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-04-09 rockdaboot StatusNone => Invalid
        Open/ClosedOpen => Closed
    2019-04-09 None Attached File- => Added choco_install_wget_libwinpthread_error.png, #46736
        Attached File- => Added win_wget_https_error.png, #46737

    Back to the top


    Powered by Savane 3.9