bugGNU Wget - Bugs: bug #54826, too much output on wget --version

 
 

bug #54826: too much output on wget --version

Submitter:  J <now3d>
Submitted:  Fri 12 Oct 2018 09:55:35 AM UTC
 
Category:  None Severity:  1 - Wish
Priority:  5 - Normal Status:  Wont Fix
Privacy:  Public Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  1.19.4 Operating System:  None
Reproducibility:  None Fixed Release:  None
Planned Release:  None Regression:  None
Work Required:  None Patch Included:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

( Jump to the original submission )

Fri 12 Oct 2018 02:44:28 PM UTC, comment #7: 

Oh good point, we forgot it so far :-)

At least we have to add the Copyright and bug report lines.

The Wgetrc/Locale/Compile/Link stuff should be ok with a different option, e.g. --version in combination with --debug or so.

Tim Ruehsen <rockdaboot>
Project Administrator
Fri 12 Oct 2018 02:40:53 PM UTC, comment #6: 

Good link, thank you.

at least wget2 --version doesn't have this. Let's hope no one adds it to wget2! ;-)

J <now3d>
Fri 12 Oct 2018 02:31:14 PM UTC, comment #5: 

The best reason to keep that ouput is that is was put like that ~10years (or maybe 20 ?) ago. There are production scripts out there that parse the output of wget --version.

Apart from that, you are right. And I wish we could just drop bw compat. At least that would be more fun - but we have to be responsible as well.

And LLVM is just a completely different approach to compilation / translation. LowLevelVirtualMachine... gcc could translate into it as well... but the ethics are different and thus the licenses.

And comparing clang / gcc as frontend to the C language... clang still refuses to compile nested functions which is a blocker to use it in my company. We use nested functions since 20 years, no way to rewrite the stable code (makes it much more complicated and would introduce bugs).

And gcc can so so much more, see https://www.linux.com/blog/2018/10/gcc-optimizing-linux-internet-and-everything

Tim Ruehsen <rockdaboot>
Project Administrator
Fri 12 Oct 2018 01:19:55 PM UTC, comment #4: 

There is no reason to cling to old output, just because it was put that way ~10 years ago.

Evolution, and rationalisation are vital for software. Unfortunately in software engineering there are engineers unwilling to change, that really holds back a lot of packages.

Look what happened when GCC wouldn't open up, that came back together as 2.95.

Again, look what happen when GCC again wouldn't open up. LLVM was born.

I've said my piece - I'm always positive about improving software :)

J <now3d>
Fri 12 Oct 2018 12:19:25 PM UTC, comment #3: 

Sure, you've shown that a bunch of other programs don't dump the compile time options. But that's not a rationale for removing it. I still don't see a reason why I should remove it now that it is already in there? We've had this output for ~10 years now and as a developer, I know it's been helpful on occasion when debugging something for a user.

I'm closing this bug for now. If you have a good reason for why it should not be there, apart from, "I don't like it", or "the others don't do it", please feel free to re-open.

Darshit Shah <darnir>
Project Administrator
Fri 12 Oct 2018 11:44:48 AM UTC, comment #2: 

wget is a user application. No other GNU package clutters the --version output in such a manner. What's the rationale for dumping the build config into the --version output? I can't see any valid reason to keep build config output there.

jonny@asus:~$ gcc --version
gcc (Ubuntu 7.3.0-27ubuntu1~18.04) 7.3.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

jonny@asus:~$ bash --version
GNU bash, version 4.4.19(1)-release (x86_64-pc-linux-gnu)
Copyright © 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

This is free software; you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
jonny@asus:~$ ls --version
ls (GNU coreutils) 8.28
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Richard M. Stallman and David MacKenzie.
jonny@asus:~$ cp --version
cp (GNU coreutils) 8.28
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Torbjorn Granlund, David MacKenzie and Jim Meyering.
jonny@asus:~$ ld --version
GNU ld (GNU Binutils for Ubuntu) 2.30
Copyright (C) 2018 Free Software Foundation, Inc.
This program is free software; you may redistribute it under the terms of
the GNU General Public Licence version 3 or (at your option) a later version.
This program has absolutely no warranty.
jonny@asus:~$

J <now3d>
Fri 12 Oct 2018 10:01:27 AM UTC, comment #1: 

Why exactly? As a developer I like that information in the --version output since it gives me clear information about the build when trying to debug an issue remotely.

And I don't see how a little extra information in the --version output harms anything at all. Do you have any concrete reasons apart from a personal preference?

Darshit Shah <darnir>
Project Administrator
Fri 12 Oct 2018 09:55:35 AM UTC, original submission:  

Hello

I noticed contary to other GNU tools, wget --version has a lot of extra output about the compiler build. Can that be removed?

If needed, wget --build-info could be added?

Thanks, Jonny

$ wget --version
GNU Wget 1.19.4 built on linux-gnu.

-cares +digest -gpgme +https +ipv6 +iri +large-file -metalink +nls
+ntlm +opie +psl +ssl/openssl

Wgetrc:
    /etc/wgetrc (system)
Locale:
    /usr/share/locale
Compile:
    gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC="/etc/wgetrc"
    -DLOCALEDIR="/usr/share/locale" -I. -I../../src -I../lib
    -I../../lib -Wdate-time -D_FORTIFY_SOURCE=2 -DHAVE_LIBSSL -DNDEBUG
    -g -O2 -fdebug-prefix-map=/build/wget-LB8XFP/wget-1.19.4=.
    -fstack-protector-strong -Wformat -Werror=format-security
    -DNO_SSLv2 -D_FILE_OFFSET_BITS=64 -g -Wall
Link:
    gcc -DHAVE_LIBSSL -DNDEBUG -g -O2
    -fdebug-prefix-map=/build/wget-LB8XFP/wget-1.19.4=.
    -fstack-protector-strong -Wformat -Werror=format-security
    -DNO_SSLv2 -D_FILE_OFFSET_BITS=64 -g -Wall -Wl,-Bsymbolic-functions
    -Wl,-z,relro -Wl,-z,now -lpcre -luuid -lidn2 -lssl -lcrypto -lpsl
    ftp-opie.o openssl.o http-ntlm.o ../lib/libgnu.a

Copyright (C) 2015 Free Software Foundation, Inc.
Licence GPLv3+: GNU GPL version 3 or later
<http://www.gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Originally written by Hrvoje Niksic <hniksic@xemacs.org>.
Please send bug reports and questions to <bug-wget@gnu.org>.

J <now3d>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rockdaboot (Posted a comment)
  • -email is unavailable- added by darnir (Posted a comment)
  • -email is unavailable- added by now3d (Submitted the item)
  •  

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-10-12 darnir StatusNone Wont Fix
        Open/ClosedOpen Closed
    2018-10-12 darnir Severity3 - Normal 1 - Wish

    Back to the top


    Powered by Savane 3.9