bugGNU Wget - Bugs: bug #53884, Can wget (and any GNU projects)...

 
 

bug #53884: Can wget (and any GNU projects) avoid spitting non-ASCII on the command line???

Submitter:  None
Submitted:  Sat 12 May 2018 08:52:55 AM UTC
 
Category:  User Interface Severity:  3 - Normal
Priority:  5 - Normal Status:  Invalid
Privacy:  Public Assigned to:  None
Originator Name:  bliako Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  None
Operating System:  GNU/Linux Reproducibility:  Every Time
Fixed Release:  None Planned Release:  None
Regression:  None Work Required:  None
Patch Included:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Mon 14 May 2018 03:00:06 AM UTC, comment #1: 

I've noticed this before but never really thought about it.  However, it seems likely that this behavior might be modulated by the LANG* environment variables.

I checked in an Emacs shell window, and wget did use non-ASCII quote characters.  But also,
$ printenv | grep LANG
LANG=en_US.UTF-8
GDM_LANG=en_US.UTF-8
$

If I do
$ LANG=en_US wget google.com
wget limits itself to ASCII quotes.

So it seems likely that the LANG variable is specified to tell what character set the program may use, and the relevant libraries respect that.

Dale Worley <worley>
Sat 12 May 2018 08:52:55 AM UTC, original submission:  

The problem is when I am using wget (many thanks for providing this excellent and free software) from the console of my Fedora/Linux machine (console, no X-server running) it prints various messages which contain non-ASCII characters, for example the saved filename is enclosed in some form of quotations. Apart from the horrible aesthetics of such decision, copying and pasting what is inside the quotation marks (via mouse double-click) is a mess because the marks are included in the text and when pasting to the console or to a file, the non-ASCII characters are copied too, thus polluting my files and making running a command via pasting fail.

In my opinion, a program using non-ASCII characters in its reporting is a decision not to be taken lightly. There is no point to enclose a filename in inverted commas rather than the traditional double quote. In my own aesthetics book, this is a faux-pas but usually programmers get rid of it after graduating primary school, circa 10 years old.

At least make printing non-ASCII characters optional via a switch.

Best wishes,

bliako.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by darnir (Updated the item)
  • -email is unavailable- added by worley (Posted a comment)
  •  

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-11-12 darnir StatusNone Invalid
        Open/ClosedOpen Closed

    Back to the top


    Powered by Savane 3.9