bugGNU nano - Bugs: bug #53532, do_scroll_up/down missing in...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #53532: do_scroll_up/down missing in v2.9.4+ when configured with --disable-help

Submitted by:  None
Submitted on:  Sat 31 Mar 2018 12:35:52 PM UTC  
 
Severity:  3 - Normal Status:  Fixed
Assigned to:  Benno Schulenberg <bens> Open/Closed:  Closed

Sat 28 Apr 2018 09:15:51 AM UTC, comment #5: 

The fix has been released in 2.9.6.  Thanks again for reporting.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sun 01 Apr 2018 11:30:51 AM UTC, comment #4: 

Thanks for the quick reply/fix! The project is a fork of a project where size was important, but I have a bit beefier hardware and prefer a few more features. In any case- I confirmed the fix is good, error is not present for me on current master. Thanks!

Jeffrey Hufford <someburner>
Sun 01 Apr 2018 08:06:46 AM UTC, comment #3: 

By the way, since you're disabling a bunch of stuff, it seems you want to make nano as small as reasonably possible.  You may want to consider adding: --disable-extra --disable-histories --disable-libmagic --disable-mouse --disable-operatingdir.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 31 Mar 2018 02:59:35 PM UTC, comment #2: 
Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 31 Mar 2018 02:58:12 PM UTC, comment #1: 

Oh, dang...  Apparently I forgot to do a 'git add src/global.c' -- because I remember making the necessary changes for commit 1fb3218a.  :|

Thanks for reporting.  I made the changes again and committed them in a865c25e.

Benno Schulenberg <bens>
Project AdministratorIn charge of this item.
Sat 31 Mar 2018 12:35:52 PM UTC, original submission:  

With autotools 1.15 I am not able to compile v2.9.4/v2.9.5 with the --disable-help configuration. Host: x64_86, Target: arm.

v2.9.3 and earlier compiles fine with the following:

cd nano && CC=$(CC) STRIP=$(STRIP) \
autoreconf -sfi && automake -a && \
CFLAGS="-Os -Wall $(EXTRACFLAGS) -I$(TOP)/libncurses/staged/usr/include -ffunction-sections -fdata-sections" \
CPPFLAGS="-Os -Wall $(EXTRACFLAGS) -I$(TOP)/libncurses/staged/usr/include -ffunction-sections -fdata-sections" \
LDFLAGS="$(LDFLAGS) -L$(TOP)/libncurses/staged/usr/lib -ffunction-sections -fdata-sections -Wl,--gc-sections -fPIC" \
$(CONFIGURE) --prefix=/usr --sysconfdir=/etc \
--disable-browser \
--disable-help \
--disable-justify \
--disable-speller \
--disable-tabcomp \
--disable-wrapping \
--enable-color \
--enable-nanorc \
--disable-nls \
--enable-utf8

However, with 2.9.4/2.9.5, I get this error:

mv -f .deps/files.Tpo .deps/files.Po
arm-brcm-linux-uclibcgnueabi-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I..  -DLOCALEDIR=\"/usr/share/locale\" -DSYSCONFDIR=\"/etc\" -I../lib -I../lib -Os -Wall -DLINUX26 -DCONFIG_BCMWL5 -DCONFIG_BCMWL6 -DCONFIG_BCMWL6A -DCONFIG_BCM7 -DPART_JFFS2_GAP=0UL -pipe -fno-strict-aliasing -DBCMWPA2 -DBCMARM -marm  -DTCONFIG_NVRAM_64K -DLINUX_KERNEL_VERSION=132644 -DUSE_COLOR -I/root/t0/tomato-slice/release/src-rt-7.x.main/src/router/libncurses/staged/usr/include -ffunction-sections -fdata-sections  -Os -Wall -DLINUX26 -DCONFIG_BCMWL5 -DCONFIG_BCMWL6 -DCONFIG_BCMWL6A -DCONFIG_BCM7 -DPART_JFFS2_GAP=0UL -pipe -fno-strict-aliasing -DBCMWPA2 -DBCMARM -marm  -DTCONFIG_NVRAM_64K -DLINUX_KERNEL_VERSION=132644 -DUSE_COLOR -I/root/t0/tomato-slice/release/src-rt-7.x.main/src/router/libncurses/staged/usr/include -ffunction-sections -fdata-sections -Wall -MT global.o -MD -MP -MF .deps/global.Tpo -c -o global.o global.c
global.c: In function ‘shortcut_init’:
global.c:863:15: error: ‘do_scroll_up’ undeclared (first use in this function)
global.c:863:15: note: each undeclared identifier is reported only once for each function it appears in
global.c:865:15: error: ‘do_scroll_down’ undeclared (first use in this function)
global.c: In function ‘strtosc’:
global.c:1530:13: error: ‘do_scroll_up’ undeclared (first use in this function)
global.c:1532:13: error: ‘do_scroll_down’ undeclared (first use in this function)
Makefile:1569: recipe for target 'global.o' failed
make[7]: *** [global.o] Error 1


The error goes away if I remove "--disable-help".

Anonymous

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by someburner (Posted a comment)
  • -email is unavailable- added by bens (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-04-28 bens Open/ClosedOpen => Closed
    2018-03-31 bens StatusNone => Fixed
        Assigned toNone => bens

    Back to the top


    Powered by Savane 3.7