bugGNU Screen - Bugs: bug #47247, Unable to send certain sequences...

 
 

bug #47247: Unable to send certain sequences of characters via -X stuff

Submitted by:  Max Rozenoer <astgtciv>
Submitted on:  Wed 24 Feb 2016 06:56:42 PM UTC  
 
Category:  User Interface Severity:  3 - Normal
Priority:  5 - Normal Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Closed Release:  4.3.1
Fixed Release:  None Planned Release:  None
Work Required:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Mon 09 Jan 2017 09:31:56 PM UTC, comment #6: 

OK, I have a workflow that involves sending text to an application running in a screen session. I don't know what your use-case is, and I would like to hear more about it and what your code is doing. But given that users can run virtually anything inside screen, and that "$" might mean something important to any given application, breaking every existing use of "stuff" with "$" seems like a bad idea to me. I recommend reverting this change and putting your code which parses "$" into the data flow of a new command, e.g. "stuffesc" or whatever.

Frederick Eaton <misfit>
Mon 09 Jan 2017 09:03:17 PM UTC, comment #5: 

This behaviour was introduced by:

http://git.savannah.gnu.org/cgit/screen.git/commit/?h=screen-v4&id=98b6b4105b60150c5bf9d022b2e7de698a62a797

to me parsing passed stuff makes sense, hence the need for double escaping things.

Amadeusz Sławiński <amade>
Project Administrator
Fri 09 Dec 2016 08:38:30 PM UTC, comment #4: 

I also have trouble on 4.3.1 with

    screen -X stuff 'test$hello'

The '$hello' disappears. If do

    screen -X stuff 'test$ hello'

then it works. I tried escaping the '$' with '\' but no luck. Please fix this, it's a regression. Thanks.

Frederick Eaton <misfit>
Mon 04 Jul 2016 06:56:10 PM UTC, comment #3: 

Everything works correctly it's caused by shell escaping slashes first and then screen escaping them itself

shell input \\\\ is passed as argument to screen as \\ and screen outputs \

Amadeusz Sławiński <amade>
Project Administrator
Thu 25 Feb 2016 11:25:15 AM UTC, comment #2: 

Workaround: replace double backslashes by 4 backslashes >>> -X stuff \\\\ <<<<, and a single backslash will be stuffed into the target.

Max Rozenoer <astgtciv>
Wed 24 Feb 2016 07:00:25 PM UTC, comment #1: 

Actually, double quote is irrelevant - even simple >>> \\ <<< causes this behavior.

Max Rozenoer <astgtciv>
Wed 24 Feb 2016 06:56:42 PM UTC, original submission:  

In Screen v4.3.1 (and also v4.2.1) on Mac OS X, I am unable to send >>> -X stuff \\\" <<< - nothing appears in the target window. In v4.00.03 (FAU) 23-Oct-06  (which shipped with MacOS), this sequence sends just fine and shows up as >>> \" <<<.

Max Rozenoer <astgtciv>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by misfit (Posted a comment)
  • -email is unavailable- added by amade (Posted a comment)
  • -email is unavailable- added by astgtciv (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-07-04 amade StatusNone => Invalid
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5