bugGNU GRUB - Bugs: bug #22398, GRUB makes BIOS poke CD-ROM at...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #22398: GRUB makes BIOS poke CD-ROM at boot on Acer5633 notebook

Submitted by:  bughunter2 <bughunter2>
Submitted on:  Fri 22 Feb 2008 09:53:43 PM UTC  
 
Category:  Booting Severity:  Major
Priority:  5 - Normal Item Group:  Action Request
Status:  Wont Fix Privacy:  Public
Assigned to:  None Originator Name: 
Open/Closed:  Closed Release:  1.96
Release:  1.96 Reproducibility:  Every Time
Planned Release:  None

( Jump to the original submission)

Fri 18 Sep 2009 12:17:14 PM UTC, comment #7: 

No code which is written in C is executed in real mode.
Only some ASM code is executed there, surrounded by "call prot_to_real" and "call real_to_prot"

Felix Zielcke <fzielcke>
Project Member
Fri 18 Sep 2009 11:16:13 AM UTC, comment #6: 

I just stumbled upon this again.

After reading the report and replies, I think it may still be useful to indeed move the code to the biosdisk module (heh, it was only later that I realized 'mods' of course are the compiled modules). My first thought was putting the code in biosdisk.c, but I'm not sure if we're in real mode there?

bughunter2 <bughunter2>
Thu 20 Mar 2008 05:06:19 AM UTC, comment #5: 

> So essentially what you want is GRUB to include documentation about a bug that is in your BIOS?


Well, essentially, yes. But is this such a weird idea? When people find GRUB not working the first place they will/should check is the documentation.
Aren't there any other BIOSes that have at least some problems with GRUB? If not, then I can understand you do not want to include it in the documentation.

About the patch:
Does biosdisk.mod already reset the disk system with `int 0x13'? If so, startup.S should just stop calling `int 0x13'.
And also, what're these mod things? Where can I read what file belongs to what module?

bughunter2 <bughunter2>
Thu 20 Mar 2008 02:08:13 AM UTC, comment #4: 

Now that I think of it, I don't see why the initialisation in startup.S should be playing with hard drives at all.  Perhaps this should be moved to biosdisk.mod, and this way you can avoid it entirely by not loading biosdisk.mod (e.g. using ata.mod instead).

Can you send a patch for that?

Robert Millan <robertmh>
Project Administrator
Thu 20 Mar 2008 01:49:29 AM UTC, comment #3: 

So essentially what you want is GRUB to include documentation about a bug that is in your BIOS?

Robert Millan <robertmh>
Project Administrator
Wed 19 Mar 2008 10:31:44 PM UTC, comment #2: 

You're right. It's better to just edit the source. But there are users out there that have the same notebook and don't know how to edit/patch the source. Maybe this could be documented somewhere (FAQ?, not that it really is frequently asked though, I think).

bughunter2 <bughunter2>
Wed 19 Mar 2008 10:26:44 PM UTC, comment #1: 

Sorry, but your BIOS is buggy.  It's not worth to work around this IMO, because we'd run the risk of uncovering other (much worse) bugs.

As for making it configurable, sounds too much like "feature creep" to me.  Just edit the source!

Robert Millan <robertmh>
Project Administrator
Fri 22 Feb 2008 09:53:43 PM UTC, original submission:  

When GRUB is booting, the CD-ROM drive spins up, stops, spins up and then
finally GRUB may continue booting.

This is caused by `int $0x13' in `kern/i386/pc/startup.S'. It should
reset the disk system, but on my system it seems to affect the CD-ROM drive
too. It only happens when a CD-ROM is in the drive. I had a bootable CD-ROM
in the drive (I don't know if it would make a difference with a normal CD-ROM).

It would be nice to make it a configurable item whether or not the `int $0x13'
will be executed. I don't know if it would be easy or possible at all to make
such a low-level thing configurable.

I've included a patch.

bughunter2 <bughunter2>

 

Attached Files
file #15096:  startup.S.patch added by bughunter2 (39B - text/x-patch)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by fzielcke (Posted a comment)
  • -email is unavailable- added by robertmh (Posted a comment)
  • -email is unavailable- added by bughunter2 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2009-09-18 fzielcke ReleaseNone => 1.96
    2008-03-19 robertmh StatusNone => Wont Fix
        Open/ClosedOpen => Closed
    2008-02-22 bughunter2 Attached File- => Added startup.S.patch, #15096

    Back to the top


    Powered by Savane 3.6