taskGnash - The GNU Flash player - Tasks: task #9300, Configuration support for gnash...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

task #9300: Configuration support for gnash python

Submitted by:  Sandro Santilli <strk>
Submitted on:  Mon 06 Apr 2009 08:42:39 AM UTC  
 
Should Start On: Wed 15 Apr 2009 06:00:00 AM UTCShould be Finished on: Wed 15 Apr 2009 06:00:00 AM UTC
Category: in progressPriority: 5 - Normal
Status: Ready For TestPrivacy: Public
Percent Complete: 100%Assigned to: Rob Savoye <rsavoye>
Open/Closed: OpenEffort: 0.00

(Jump to the original submission Jump to the original submission)

Mon 20 Apr 2009 03:10:27 PM UTC, comment #8:

This appears to be a packaging bug for Debian Lenny and Ubuntu Intrepid, Gnash can find the boost_python library, but can't use it
because it appears to have the boost configuration wrong for the compiler version. Removing the development packages for Boost 1.34 and upgrading to Boost 1.35 or Boost 1.37 fixes the problem. On Fedora 10 and 11, it's always worked with the default packages.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Sat 18 Apr 2009 12:07:46 AM UTC, comment #7:

I tried --enable-python on an Ubuntu Intrepid machine with the default packages, and configure found boost_python just fine.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Fri 17 Apr 2009 10:11:32 AM UTC, comment #6:

This is to report that dropping any boost-python package
and reinstalling it doesn't fix the issue.
I did verify that the drop was effective, and gnash correctly
dumped an ERROR for not finding the library in that case.

Sandro Santilli <strk>
Project Member
Fri 17 Apr 2009 08:20:51 AM UTC, comment #5:

On Ubuntu-8.10, there boost_python library name found
is one that points to nowhere. Sounds like a bug in Ubuntu itself.

Gnash finds it to be boost_python-gcc41-1_34_1.so, and
/usr/lib/libboost_python-gcc41-1_34_1.so is a symlink to
libboost_python-gcc41-1_34_1-py25.so, which does NOT exist.

Instead, libboost_python-gcc42-1_34_1-py25.so exists
which is symlinked from the top-level libboost_python.so

I've no idea where the bug comes from, most likely an ubuntu
dist upgrade, as dpkg -S doesn't know about it either:
dpkg: /usr/lib/libboost_python-gcc41-1_34_1.so not found.

Sandro Santilli <strk>
Project Member
Thu 16 Apr 2009 04:24:45 PM UTC, comment #4:

Ok, as of revno #10801, configure finds the boost_python library when python is enabled.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Thu 16 Apr 2009 07:11:54 AM UTC, comment #3:

The new python.m4 should also check/find libboost_python

Sandro Santilli <strk>
Project Member
Thu 16 Apr 2009 12:13:52 AM UTC, comment #2:

I added support for a --enable-python option, and made building the python module conditional based on this. It also uses python-config to get the headers and libraries needed for Python development. Now all somebody has to do is fix the module so it actually compiles.:-) Anyway, checked in as of revno 10794.

Just as a note, Sugar Labs is using a modified version of this for Gnash->Sugar integration.

Rob Savoye <rsavoye>
Project AdministratorIn charge of this item.
Mon 06 Apr 2009 10:08:06 AM UTC, comment #1:

Also, the install rule seems broken

Sandro Santilli <strk>
Project Member
Mon 06 Apr 2009 08:42:39 AM UTC, original submission:

Currently the python module is never built.
Configuration support should add an --enable-python configure switch or similar, and look for 'python' boost lib and headers.

Sandro Santilli <strk>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by rsavoye (Posted a comment)
  • -unavailable- added by strk (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 18 Apr 2009 12:07:46 AM UTCrsavoyeCategoryNone=>in progress
    Thu 16 Apr 2009 12:14:31 AM UTCrsavoyeAssigned toNone=>rsavoye
    Thu 16 Apr 2009 12:13:52 AM UTCrsavoyeShould Start OnSun 05 Apr 2009 10:00:00 PM UTC=>Wed 15 Apr 2009 06:00:00 AM UTC
      Should be Finished onSun 05 Apr 2009 10:00:00 PM UTC=>Wed 15 Apr 2009 06:00:00 AM UTC
      StatusNone=>Ready For Test
      Percent Complete0%=>100%

    Back to the top


    Powered by Savane 3.1-cleanup