helpGnuTLS - Support: sr #108343, gnutls 3.2.2 breaks tls...


sr #108343: gnutls 3.2.2 breaks tls decryption: "Decryption has failed."

Submitted by:  Afri Qhdoe <qdoe>
Submitted on:  Wed 24 Jul 2013 07:56:09 AM UTC  
Votes:  150  
Category: Core libraryPriority: 5 - Normal
Severity: 4 - ImportantStatus: None
Privacy: PublicAssigned to: None
Open/Closed: ClosedOperating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):

You are not logged in

Please log in, so followups can be emailed to you.


(Jump to the original submission Jump to the original submission)

Wed 31 Jul 2013 07:11:38 PM UTC, comment #6:

gnutls-3.2.3 fixes all issues for me. thanks. whatever that was :>

Afri Qhdoe <qdoe>
Thu 25 Jul 2013 08:04:47 AM UTC, comment #5:

Oh. Sorry!

Peter Weber <hoschi>
Wed 24 Jul 2013 03:07:31 PM UTC, comment #4:

On 2013-07-24 Peter Weber <> wrote:

> The testsuite has some glitches:

The gnutls testsuite works in non-parallel mode (i.e. make check withouut -jN with N>1).

I was asking about the glib-networking testsuite, not the gnutls one., though. ;-)

cu Andreas

Andreas Metzler <ametzler>
Wed 24 Jul 2013 02:27:48 PM UTC, comment #3:

The testsuite has some glitches:

Peter Weber <hoschi>
Wed 24 Jul 2013 11:20:39 AM UTC, comment #2:

Out of interest I have tried re-building Debian's (and Ubuntu's) glib-networking packages against gnutls 3.x. - While the build succeeded the testsuite failed for me. Are you running the testsuite in Archlinux, does it report any errors?

cu Andreas

Andreas Metzler <ametzler>
Wed 24 Jul 2013 09:06:50 AM UTC, comment #1:

This bug was reported multiple times on the mailing list:

I'm afraid we confused Nikos Mavrogiannopoulos a little bit.

Peter Weber <hoschi>
Wed 24 Jul 2013 07:56:09 AM UTC, original submission:

An upgrade of gnutls to 3.2.2 breaks pretty much everything that uses TLS. I'm using archlinux. I discovered this issue using weechat, telling me:

> irc: reading data on socket: error -24 Decryption has failed.

The guys at #weechat told me there are more people complaining and it's a gnutls issue. see

downgrading gnutls "fixes" this. could you please look into it?

Related broken projects:
- epiphany
- webkit

> Error reading data from TLS socket: Decryption has failed.

This bug was poorly reported on the mailing list some days ago (it looked like a connection error). Yet, I'm trying to do better but I'm sorry I don't know how to provide a better back trace or something. Maybe you can guide me? I tried to attach gnutls-cli or weechat to gdb but without success of extracting the error message.

Afri Qhdoe <qdoe>


(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):

No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -unavailable- added by nmav (Updated the item)
  • -unavailable- added by floft (Voted in favor of this item)
  • -unavailable- added by hoschi (Voted in favor of this item)
  • -unavailable- added by hoschi (Posted a comment)
  • -unavailable- added by qdoe (Submitted the item)

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 150 encouragements so far.

    Only logged-in users can vote.


    Please enter the title of George Orwell's famous dystopian book (it's a date):



    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 06 Feb 2014 09:54:44 AM UTCnmavOpen/ClosedOpen=>Closed
    Thu 25 Jul 2013 02:10:40 AM UTCfloftCarbon-Copy-=>Added floft
    Wed 24 Jul 2013 09:07:07 AM UTChoschiCarbon-Copy-=>Added hoschi

    Back to the top

    Powered by Savane 3.1-cleanup