helpGnuTLS - Support: sr #108004, Since GnuTLS 3.0.17 upgrade,...

 
 

sr #108004: Since GnuTLS 3.0.17 upgrade, evolution 3.2.x and newer cannot synchronise with google calendar account

Submitted by:  Frederic Bezies <fredbezies>
Submitted on:  Tue 27 Mar 2012 07:10:56 PM UTC  
 
Category:  None Priority:  5 - Normal
Severity:  3 - Normal Status:  Done
Privacy:  Public Assigned to:  Nikos Mavrogiannopoulos <nmav>
Open/Closed:  Closed Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Fri 06 Apr 2012 10:33:35 AM UTC, comment #10: 

I can confirm that 3.0.18 fixed this issue for me (Arch Linux).  Thank you.

Darren Davison <darrend>
Mon 02 Apr 2012 06:53:57 PM UTC, comment #9: 

GnuTLS 3.0.18 should solve this issue.

Nikos Mavrogiannopoulos <nmav>
Project AdministratorIn charge of this item.
Thu 29 Mar 2012 09:11:57 AM UTC, comment #8: 

Thanks a lot for the info. Looks like this annoying will be "dead" soon ;)

Frederic Bezies <fredbezies>
Thu 29 Mar 2012 09:05:48 AM UTC, comment #7: 

Hello it seems a fix reverted the behavior of sending GNUTLS_E_PREMATURE_TERMINATION to sending GNUTLS_E_UNEXPECTED_PACKET_LENGTH. I'll correct it on the next release and add a test case to prevent this from happening.

Anonymous
Wed 28 Mar 2012 07:38:27 PM UTC, comment #6: 

I made a wireshark dump under virtualbox. Will post a new one with my real computer, upgraded to gnome 3.4.

For info, on my real computer :

Name                  : glib-networking
Version               : 2.31.22-1

Frederic Bezies <fredbezies>
Wed 28 Mar 2012 03:26:42 PM UTC, comment #5: 

[fred@fredo-arch ~]$ pacman -Qi glib-networking
Name                  : glib-networking
Version               : 2.30.2-1

Well, glib-networking was last updated in january 2012, gnutls in march 2012.

What to do now ?

Frederic Bezies <fredbezies>
Wed 28 Mar 2012 03:11:25 PM UTC, comment #4: 

What version of glib-networking do you have installed? If it's 2.28 (or rather, less than 2.29.92), then you need to upgrade that. (2.28 was never tested against gnutls 3.0, and so doesn't know about the GNUTLS_E_PREMATURE_TERMINATION error code.)

Dan Winship <danw>
Wed 28 Mar 2012 08:21:28 AM UTC, comment #3: 

If your network interface is eth0, do "wireshark -i eth0", and Click on start capture. You then start the program in question and try to connect to the server. After it fails you stop the capture, save the file and send it to me.

Anonymous
Wed 28 Mar 2012 08:13:23 AM UTC, comment #2: 

No problem. Just tell me how to make this capture and I will to do asap. I'm not a big friend of wireshark :(

Frederic Bezies <fredbezies>
Wed 28 Mar 2012 07:47:02 AM UTC, comment #1: 

Hello,
 the warning you get is unrelated with gnutls. Could you please make a capture with wireshark of the transaction and send it to me? (nmav@gnutls.org)

Anonymous
Tue 27 Mar 2012 07:10:56 PM UTC, original submission:  

Hello.

On my Archlinux, I saw that since GnuTLS was upgraded to version 3.0.17, Evolution is not able to synchronise with my google calendar account.

Here is the error message I get :

"Unable to open the calendar: The HTTP status code returned (6) is unexpected
(Error reading data connector TLS: A TLS packet with incorrect length was
received.)"

And in terminal, I got this error :

"(evolution: 1774): e-data-server-ui-WARNING **: The keyring is unusable: no
host name or user"

For the first error message, I think a change in GnuTLS broke evolution synchronisation.

Frederic Bezies <fredbezies>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #25506:  patch.txt added by None (502B - text/plain)
file #25497:  dump2 added by fredbezies (21KiB - application/octet-stream - Another WireShark dump.)
file #25488:  dump added by fredbezies (7KiB - application/octet-stream - Wireshark dump you asked for. I tried to synchronize my google calendar with evolution.)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by darrend (Posted a comment)
  • -email is unavailable- added by nmav (Posted a comment)
  • -email is unavailable- added by danw (Posted a comment)
  • -email is unavailable- added by fredbezies (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2012-04-06 nmav Open/ClosedOpen => Closed
    2012-04-02 nmav StatusNone => Done
        Assigned toNone => nmav
    2012-03-29 None Attached File- => Added patch.txt, #25506
    2012-03-28 fredbezies Attached File- => Added dump2, #25497
    2012-03-28 fredbezies Attached File- => Added dump, #25488

    Back to the top


    Powered by Savane 3.7