helpGnuTLS - Support: sr #107860, The read_file function is too...


sr #107860: The read_file function is too generic, clashes with similarly named functions in user applications

Submitted by:  Martin Storsjö <mstorsjo>
Submitted on:  Mon 31 Oct 2011 03:24:38 PM UTC  
Category:  Core library Priority:  5 - Normal
Severity:  2 - Minor Status:  Done
Privacy:  Public Assigned to:  Nikos Mavrogiannopoulos <nmav>
Open/Closed:  Closed Operating System:  GNU/Linux

Add a New Comment (Rich Markup)

You are not logged in

Please log in, so followups can be emailed to you.


Wed 16 Nov 2011 01:54:18 PM UTC, comment #4: 

The new solution using #defines seem to work just fine as well. Thanks!

Martin Storsjö <mstorsjo>
Wed 16 Nov 2011 01:28:20 PM UTC, comment #3: 

I've modified the solution here to use config.h #define's instead.  Please test.  I'm closing this meanwhile...

Simon Josefsson <jas>
Project Administrator
Tue 01 Nov 2011 08:37:23 AM UTC, comment #2: 

Great, thanks!

Martin Storsjö <mstorsjo>
Tue 01 Nov 2011 07:43:51 AM UTC, comment #1: 

Thanks for reporting that. I have renamed it to gl_read_file() so it shouldn't class any more.

Nikos Mavrogiannopoulos <nmav>
Project AdministratorIn charge of this item.
Mon 31 Oct 2011 03:24:38 PM UTC, original submission:  

The read_file function is a very generic name, which can cause clashes with functions named similarly in calling applications, if linking gnutls statically. (One concrete case was in the ffmpeg/avconv applications, where the function has been renamed as a preparation for adding gnutls support:;a=commitdiff;h=02170990fdb2a05c6eaf5fd449f440ec51c0f822)

The attached patch renames this function and the other ones in gl/read-file.h, by adding a leading underscore. Any other prefix that would be internal to gnutls would work just as well.

Martin Storsjö <mstorsjo>


(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:

Attached Files


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -email is unavailable- added by jas (Posted a comment)
  • -email is unavailable- added by nmav (Posted a comment)
  • -email is unavailable- added by mstorsjo (Submitted the item)

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.




    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2011-11-16 jas Open/ClosedOpen => Closed
    2011-11-01 nmav StatusNone => Done
        Assigned toNone => nmav
    2011-10-31 mstorsjo Attached File- => Added 0001-Rename-the-read_file-function-family.patch, #24255

    Back to the top

    Powered by Savane 3.7