patchGnash - The GNU Flash player - Patches: patch #7394, Change npapi plugin description to...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

patch #7394: Change npapi plugin description to exactly match Adobe's player

Submitted by:  Tim Retout <diocles>
Submitted on:  Wed 17 Nov 2010 07:02:56 PM UTC  
 
Category: pluginPriority: 5 - Normal
Status: NonePrivacy: Public
Assigned to: NoneOpen/Closed: Open

Wed 17 Nov 2010 08:10:16 PM UTC, comment #1:

youtube.com checks for 'gnash' in the plugin description. If found, it delivers supported AVM1 movie instead of the unsupported AVM2 one.
We don't want to break that mechanism.
Ideally, we should make it easier for users to specify the plugin description. One idea could be adding a --plugin-description option to the standalone gnash and have it called by the plugin, so that you could use the GTK preferences editor to change it.

Sandro Santilli <strk>
Project Member
Wed 17 Nov 2010 07:02:56 PM UTC, original submission:

I'm attaching the patch that I sent to the mailing list back in July, so that it doesn't get lost.

Some JavaScript libraries (e.g. Glow, used on bbc.co.uk) detect the Flash plugin's presence and version by parsing the plugin description. Unfortunately the copyright notice was confusing these libraries.

Affected sites include at least BBC iPlayer and BBC News. For instance, the '7 day quiz' (which has only a couple of minor bugs in gnash):

http://www.bbc.co.uk/news/magazine-11737726

I have observed the same problem on non-BBC sites, but I don't have a link to hand. (I think I got them out of the bug tracker or the gnash mailing list.)

The problem with applying this straight away is that YouTube relies on the plugin description to serve up AVM1 to Gnash.

Tim Retout <diocles>

 

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by strk (Posted a comment)
  • -unavailable- added by diocles (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 17 Nov 2010 07:02:56 PM UTCdioclesAttached File-=>Added 0001-Change-npapi-plugin-description-to-exactly-match-Ado.patch, #22041

    Back to the top


    Powered by Savane 3.1-cleanup