newsGNU FreeDink - News

 
 

Compatibility mode

Item posted by Sylvain Beucler <Beuc> on Thu 03 Jul 2008 07:19:54 PM UTC.

After much thinking I decided to try and support both original v1.07 and v1.08 in the same engine. FreeDink now starts in v1.08 mode, and you can use the --v1.07 option to run D-Mods that don't work fine with the new engine (there's a new checkbox in the DFArc2 graphical frontend too). Currently I'm working on conditionally enabling v1.08 DinkC changes - wish me luck ;)

In other news, some big memory leaks (in the original engine's graphics management, but also in my sound port ;)) and a couple crashes have been fixed.

Back to the top

Powered by Savane 3.13-d3ae.
Corresponding source code