bugGnash - The GNU Flash player - Bugs: bug #33696, Unable to build Gnash with...

 
 

bug #33696: Unable to build Gnash with ffmpeg-0.8

Submitted by:  Igor Murzov <garik_>
Submitted on:  Sat 02 Jul 2011 05:08:17 PM UTC  
 
Category: video-ffmpegSeverity: 3 - Normal
Release: masterStatus: Fixed
Privacy: PublicAssigned to: Gabriele Giacone <gg0>
Open/Closed: Closed

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Mon 12 Sep 2011 07:21:45 AM UTC, comment #8:

sortie: for the incremental decoding work we have another ticket, use that on

Sandro Santilli <strk>
Project Member
Mon 12 Sep 2011 12:09:11 AM UTC, comment #7:

It works! Bug can be closed.

Igor Murzov <garik>
Sun 11 Sep 2011 08:21:19 PM UTC, comment #6:

I'm compiling gnash against-0.8.2 at the moment.

Compiler output related to ffmpeg part:
[code]
make[2]: Вход в каталог `/tmp/tgz/gnash/libmedia'
CXX libgnashmedia_la-AudioDecoderSimple.lo
CXX libgnashmedia_la-AudioResampler.lo
CXX libgnashmedia_la-FLVParser.lo
CXX libgnashmedia_la-MediaHandler.lo
CXX libgnashmedia_la-MediaParser.lo
CXX libgnashmedia_la-AudioDecoderFfmpeg.lo
CXX libgnashmedia_la-AudioInputFfmpeg.lo
CXX libgnashmedia_la-AudioResamplerFfmpeg.lo
In file included from ffmpeg/AudioDecoderFfmpeg.cpp:25:0:
ffmpeg/MediaParserFfmpeg.h:156:16: warning: 'ByteIOContext' is deprecated (declared at /usr/include/libavformat/avio.h:218)
ffmpeg/AudioDecoderFfmpeg.cpp: In member function 'uint8_t* gnash::media::ffmpeg::AudioDecoderFfmpeg::decodeFrame(const uint8_t*, uint32_t, uint32_t&)':
ffmpeg/AudioDecoderFfmpeg.cpp:510:27: warning: cast from type 'const uint8_t' to type 'uint8_t' casts away qualifiers
CXX libgnashmedia_la-MediaHandlerFfmpeg.lo
In file included from ffmpeg/MediaHandlerFfmpeg.cpp:26:0:
ffmpeg/MediaParserFfmpeg.h:156:16: warning: 'ByteIOContext' is deprecated (declared at /usr/include/libavformat/avio.h:218)
CXX libgnashmedia_la-MediaParserFfmpeg.lo
In file included from ffmpeg/MediaParserFfmpeg.cpp:21:0:
ffmpeg/MediaParserFfmpeg.h:156:16: warning: 'ByteIOContext' is deprecated (declared at /usr/include/libavformat/avio.h:218)
ffmpeg/MediaParserFfmpeg.cpp: In member function 'void gnash::media::ffmpeg::MediaParserFfmpeg::initializeParser()':
ffmpeg/MediaParserFfmpeg.cpp:368:5: warning: 'int init_put_byte(AVIOContext, unsigned char, int, int, void, int ()(void, uint8_t, int), int ()(void, uint8_t, int), int64_t ()(void*, int64_t, int))' is deprecated (declared at /usr/include/libavformat/avio.h:220)
ffmpeg/MediaParserFfmpeg.cpp:376:5: warning: 'int init_put_byte(AVIOContext, unsigned char, int, int, void, int ()(void, uint8_t, int), int ()(void, uint8_t, int), int64_t ()(void*, int64_t, int))' is deprecated (declared at /usr/include/libavformat/avio.h:220)
ffmpeg/MediaParserFfmpeg.cpp:378:16: warning: 'AVIOContext::is_streamed' is deprecated (declared at /usr/include/libavformat/avio.h:68)
ffmpeg/MediaParserFfmpeg.cpp:378:16: warning: 'AVIOContext::is_streamed' is deprecated (declared at /usr/include/libavformat/avio.h:68)
ffmpeg/MediaParserFfmpeg.cpp:392:8: warning: 'AVFormatParameters::prealloced_context' is deprecated (declared at /usr/include/libavformat/avformat.h:257)
ffmpeg/MediaParserFfmpeg.cpp:392:8: warning: 'AVFormatParameters::prealloced_context' is deprecated (declared at /usr/include/libavformat/avformat.h:257)
ffmpeg/MediaParserFfmpeg.cpp:394:9: warning: 'int av_open_input_stream(AVFormatContext*, AVIOContext, const char, AVInputFormat, AVFormatParameters*)' is deprecated (declared at /usr/include/libavformat/avformat.h:1072)
ffmpeg/MediaParserFfmpeg.cpp:394:74: warning: 'int av_open_input_stream(AVFormatContext*, AVIOContext, const char, AVInputFormat, AVFormatParameters*)' is deprecated (declared at /usr/include/libavformat/avformat.h:1072)
ffmpeg/MediaParserFfmpeg.cpp:402:17: warning: 'AVMetadata' is deprecated (declared at /usr/include/libavformat/avformat.h:131)
ffmpeg/MediaParserFfmpeg.cpp:404:24: warning: 'AVMetadataTag' is deprecated (declared at /usr/include/libavformat/avformat.h:132)
ffmpeg/MediaParserFfmpeg.cpp:404:30: warning: 'AVDictionaryEntry* av_metadata_get(AVDictionary, const char, const AVDictionaryEntry*, int)' is deprecated (declared at /usr/include/libavformat/avformat.h:145)
ffmpeg/MediaParserFfmpeg.cpp:405:39: warning: 'AVDictionaryEntry* av_metadata_get(AVDictionary, const char, const AVDictionaryEntry*, int)' is deprecated (declared at /usr/include/libavformat/avformat.h:145)
CXX libgnashmedia_la-VideoConverterFfmpeg.lo
CXX libgnashmedia_la-VideoDecoderFfmpeg.lo
In file included from ffmpeg/VideoDecoderFfmpeg.cpp:31:0:
ffmpeg/MediaParserFfmpeg.h:156:16: warning: 'ByteIOContext' is deprecated (declared at /usr/include/libavformat/avio.h:218)
ffmpeg/VideoDecoderFfmpeg.cpp: In member function 'std::auto_ptr<gnash::image::GnashImage> gnash::media::ffmpeg::VideoDecoderFfmpeg::decode(const uint8_t*, uint32_t)':
ffmpeg/VideoDecoderFfmpeg.cpp:362:27: warning: cast from type 'const uint8_t' to type 'uint8_t' casts away qualifiers
CXX libgnashmedia_la-VideoInputFfmpeg.lo
CXX libgnashmedia_la-AudioDecoderSpeex.lo
CXXLD libgnashmedia.la
make[2]: Выход из каталога `/tmp/tgz/gnash/libmedia'
[/code]

Igor Murzov <garik>
Sun 11 Sep 2011 06:14:14 PM UTC, comment #5:

Can anyone test against ffmpeg-0.8, so to close the bug ?

Sandro Santilli <strk>
Project Member
Sun 11 Sep 2011 09:42:50 AM UTC, comment #4:

Pushed 5c76984, chithead's patches + #if LIBAVCODEC_VERSION_MAJOR >= 53.
It just fixes build on sid, libav 0.7.1.

Gabriele Giacone <gg0>
Project MemberIn charge of this item.
Thu 28 Jul 2011 07:22:16 PM UTC, comment #3:

The audio and video decode patches does not check how much of the packet FFmpeg used -- the documentation tells us to provide the unused portion at the next call, but currently that is discarded.

I am working on avoiding this discarding anyways, so I'll keep these patches in mind. The rest of the patches should be trivial to add with a dozen #ifdefs.

Jonas 'Sortie' Termansen <sortie>
Project Member
Sat 02 Jul 2011 08:58:16 PM UTC, comment #2:

With the attached patches, gnash should build against ffmpeg-0.8

(file #23615, file #23616)

Chi-Thanh Christopher Nguyen <chithanh>
Sat 02 Jul 2011 06:19:52 PM UTC, comment #1:

av_parser_parse has been marked as deprecated after ffmpeg-0.6, now it is gone.
See also https://bugs.gentoo.org/show_bug.cgi?id=362949

(file #23612)

Chi-Thanh Christopher Nguyen <chithanh>
Sat 02 Jul 2011 05:08:17 PM UTC, original submission:

I've tried to compile gnash from master branch, but it failed with the following errors:

CXX libgnashmedia_la-AudioDecoderFfmpeg.lo
In file included from ffmpeg/AudioDecoderFfmpeg.cpp:25:0:
ffmpeg/MediaParserFfmpeg.h:152:16: warning: 'ByteIOContext' is deprecated (declared at /usr/include/libavformat/avio.h:218)
ffmpeg/AudioDecoderFfmpeg.cpp: In member function 'uint8_t* gnash::media::ffmpeg::AudioDecoderFfmpeg::decodeFrame(const uint8_t*, uint32_t, uint32_t&)':
ffmpeg/AudioDecoderFfmpeg.cpp:553:52: error: 'avcodec_decode_audio2' was not declared in this scope
ffmpeg/AudioDecoderFfmpeg.cpp: In member function 'int gnash::media::ffmpeg::AudioDecoderFfmpeg::parseInput(const uint8_t, uint32_t, const uint8_t, int)':
ffmpeg/AudioDecoderFfmpeg.cpp:667:25: error: 'av_parser_parse' was not declared in this scope
ffmpeg/AudioDecoderFfmpeg.cpp:700:1: warning: control reaches end of non-void function
make[2]: *** [libgnashmedia_la-AudioDecoderFfmpeg.lo] Ошибка 1
make[2]: Выход из каталога `/tmp/tgz/gnash/libmedia'
make[1]: *** [all-recursive] Ошибка 1
make[1]: Выход из каталога `/tmp/tgz/gnash'
make: *** [all] Ошибка 2

Igor Murzov <garik_>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #23613:  gnash-0.8.9-no-deprecated-avcodec-decode-audio.patch added by chithanh (931B - text/x-patch - patch to use avcodec_decode_audio3 instead. needs ffmpeg-0.6)
file #23612:  gnash-0.8.9-no-deprecated-avcodec-parser.patch added by chithanh (807B - text/x-patch - patch to use av_parser_parse2 instead. needs ffmpeg-0.6)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by garik (Posted a comment)
  • -unavailable- added by strk (Posted a comment)
  • -unavailable- added by gg0 (Posted a comment)
  • -unavailable- added by sortie (Updated the item)
  • -unavailable- added by chithanh (Updated the item)
  • -unavailable- added by garik_ (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 10 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 12 Sep 2011 07:21:45 AM UTCstrkStatusIn Progress=>Fixed
      Assigned tosortie=>gg0
      Open/ClosedOpen=>Closed
    Thu 28 Jul 2011 07:22:16 PM UTCsortieStatusNone=>In Progress
    Thu 28 Jul 2011 06:49:02 PM UTCsortieAssigned toNone=>sortie
    Sat 02 Jul 2011 08:58:16 PM UTCchithanhAttached File-=>Added gnash-0.8.9-no-deprecated-avcodec-audio-resample.patch, #23615
      Attached File-=>Added gnash-0.8.9-no-deprecated-avformat-metadata.patch, #23616
    Sat 02 Jul 2011 07:48:28 PM UTCchithanhAttached File-=>Added gnash-0.8.9-no-deprecated-avcodec-decode-video.patch, #23614
    Sat 02 Jul 2011 07:16:53 PM UTCchithanhAttached File-=>Added gnash-0.8.9-no-deprecated-avcodec-decode-audio.patch, #23613
    Sat 02 Jul 2011 06:19:52 PM UTCchithanhAttached File-=>Added gnash-0.8.9-no-deprecated-avcodec-parser.patch, #23612

    Back to the top


    Powered by Savane 3.1-cleanup1