bugGNU Wget - Bugs: bug #52743, calculated left time and download...

 
 

bug #52743: calculated left time and download speed freezes sometimes.

Submitted by:  Mohammad Etemaddar <metemaddar>
Submitted on:  Tue 26 Dec 2017 11:07:33 AM UTC  
 
Category:  Program Logic Severity:  3 - Normal
Priority:  5 - Normal Status:  Wont Fix
Privacy:  Public Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  1.19.1 Operating System:  GNU/Linux
Reproducibility:  None Fixed Release:  None
Planned Release:  None Regression:  None
Work Required:  None Patch Included:  None

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 09 Jan 2018 04:28:44 PM UTC, comment #1:

Hi,

Wget is built entirely without multi-threading support. Hence, the idea of having the progress printed from a second thread is not feasible.

There have been multiple attempts in the past to add threading support to Wget, but the old code base is really hard to refactor.

Instead, do take a look at GNU Wget2, a rewrite of Wget in C which was built with concurrency in mind.
https://gitlab.com/gnuwget/wget2

Darshit Shah <darnir>
Project Administrator
Tue 26 Dec 2017 11:07:33 AM UTC, original submission:

Sometimes, for some reason, the download gets in trouble and stops downloading. But the speed freezes. It doesn't show 0. It shows the download speed. Also the time freezes.
I think the "Download Speed" and "Left time" should be calculated on another thread independent than the downloading process. because whenever it freezes, these calculations also freeze.

Thanks a lot

Mohammad Etemaddar <metemaddar>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by darnir (Posted a comment)
  • -email is unavailable- added by metemaddar (Submitted the item)
  •  

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-01-09 darnir StatusNone => Wont Fix
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.3