bugGnash - The GNU Flash player - Bugs: bug #40448, ./configure doesn't complain when...


bug #40448: ./configure doesn't complain when building against unsupported ffmpeg 53.10.0

Submitted by:  Sandro Santilli <strk>
Submitted on:  Fri 01 Nov 2013 08:35:35 PM UTC  
Category: buildSeverity: 3 - Normal
Release: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):

You are not logged in

Please log in, so followups can be emailed to you.


Fri 01 Nov 2013 08:35:35 PM UTC, original submission:

According to macros/ffmpeg.m4, version 53.35.0 or greater is required, but when building against version 53.10.0 ./configure doesn't complain about it, and make fails:

ffmpeg/AudioDecoderFfmpeg.cpp:529: error: 'avcodec_decode_audio4' was not declared in this scope

Version 53.10.0 has avcodec_decode_audio3

Gabriele, ideas ?

Sandro Santilli <strk>
Project Member


(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):

No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -unavailable- added by strk (Submitted the item)

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.


    Please enter the title of George Orwell's famous dystopian book (it's a date):



    No Changes Have Been Made to This Item

    Back to the top

    Powered by Savane 3.1-cleanup