bugGNU nano - Bugs: bug #38378, nano links against libmagic, but...

 
 

bug #38378: nano links against libmagic, but libmagic needs libz and the build fails

Submitted by:  Alan Hourihane <alanh>
Submitted on:  Fri 22 Feb 2013 04:05:51 PM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: OpenRelease: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 22 Feb 2013 04:05:51 PM UTC, original submission:

I'm on a static only system, where there are no shared libraries.

libmagic.so on a shared system implicitly links libz, but nano doesn't check that.

On a static only system nano needs to link libz as well as libmagic otherwise the build fails.

Alan Hourihane <alanh>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by alanh (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup