bugGNU nano - Bugs: bug #36484, [Request] stop the information...

 
 

bug #36484: [Request] stop the information block on nano -c from jumping

Submitted by:  Sworddragon <sworddragon>
Submitted on:  Thu 17 May 2012 10:56:44 AM UTC  
 
Severity: 1 - WishStatus: Wont Fix
Assigned to: NoneOpen/Closed: Closed

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun 26 Feb 2017 08:44:05 PM UTC, comment #6:

You said that holding down will also increase the position of the column and then changing back to 1%. That does not make any sense to me as there is no reason to increase the column position if the cursor will anyway end at the start of the line with 1% for the column. An explanation I could think of is that if the user requests to go down a line nano does this internally by moving the cursor character for character to the right until the next line is reached and triggering for every cursor move the information block to update. In case this assumption is true I think that expsoing this behavior to the user is unneeded.

If this should be completely wrong I failed to understand comment #3.

Edit: Or was you pointing to that holding down could hit an empty line that would show 100% for the column and then eventually 1% on the next line? Actually that would be the obvious consequence on implementing this feature and I have interpreted comment #3 then too complex. I was thinking that you basically pointed to a case that effectively pressing down could cause the column to change from 1% without whitespaces to 1% with whitespaces which could look confusing to the user.

Sworddragon <sworddragon>
Sun 26 Feb 2017 12:38:55 PM UTC, comment #5:

Your comment does not make any sense to me.

Benno Schulenberg <bens>
Project Administrator
Sat 25 Feb 2017 01:49:43 PM UTC, comment #4:

In that case I'm wondering why nano does calculate the position for each character in the line if the user clearly requested to go to the next line and thus would not see all the calculated results.

Sworddragon <sworddragon>
Sat 25 Feb 2017 11:56:57 AM UTC, comment #3:

To explain further: the biggest problem are the percentages. When holding down <Right>, the col position will slowly increase, and will reach 100% at the end of a line, and will then drop to 1% when the cursor moves to the next line. How should it be prevented from "jumping"? Should spaces be included, so that 1% is displayed as "( 1%)"? For all three percentages? That's ugly. But if not doing that, there's no way one can stop the block from jumping. So... cantfix.

Benno Schulenberg <bens>
Project Administrator
Sat 25 Feb 2017 11:48:01 AM UTC, comment #2:

Oh. A long time ago, Chris commented something somewhere, which implied that he had tried to implement this request and had not succeeded. It sounds majorly complicated too, so I am not going to try. Also: nowadays nano can display line numbers, so the need for --constantshow has diminished considerably.

So yes, this was marked on purpose as wontfix.

Benno Schulenberg <bens>
Project Administrator
Fri 24 Feb 2017 05:59:57 PM UTC, comment #1:

The ticket got closed but I don't see a related comment. Was this just an accident or got the feature request rejected?

Sworddragon <sworddragon>
Thu 17 May 2012 10:56:44 AM UTC, original submission:

I'm using nano 2.2.6 with the option -c to see the current position in the text editor.

The problem is that the information blocks grows horizontally if for example the current line reaches the next digit but it shrinks if it looses a digit.

For example if you go from line 9 to 10 the block grows and if you go back from line 10 to 9 it shrinks. In my opinion the block shouldn't shrink but reserve the place with a whitespace. This means the block can only grow but not shrink. This will avoid a jumpy behavior if you are going fast trough a file.

Sworddragon <sworddragon>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by bens (Updated the item)
  • -unavailable- added by sworddragon (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 24 Feb 2017 12:05:42 PM UTCbensStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed
    Sat 14 Jun 2014 08:24:53 PM UTCbensSeverity3 - Normal=>1 - Wish
      SummaryThe information block on nano -c is jumping=>[Request] stop the information block on nano -c from jumping

    Back to the top


    Powered by Savane 3.1-cleanup1