bugGnash - The GNU Flash player - Bugs: bug #32195, movieclip-lockroot-loadmovie-6.swf...

 
 

bug #32195: movieclip-lockroot-loadmovie-6.swf on ovh slave

Submitted by:  Petter Reinholdtsen <pere>
Submitted on:  Thu 20 Jan 2011 06:39:45 PM UTC  
 
Category: testsuiteSeverity: 3 - Normal
Release: masterStatus: In Progress
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun 13 Mar 2011 04:24:44 PM UTC, comment #7:

http://www.gnashdev.org:8010/builders/lenny-linux-x86/builds/348/steps/make_anal/logs/stdio

Gabriele Giacone <gg0>
Project Member
Sat 19 Feb 2011 03:50:17 AM UTC, comment #6:

Reopening bug. Error below always comes out just on ovh builder (not on lenny-linux-x86-2).
Main difference I see is swfmill and mtasc are not installed on ovh. Could owner install them?

FAIL: run_swfdec_testsuite_m: movieclip-lockroot-loadmovie-6.swf:679b3cea0d9643744aa29c88ae9908e1 (traces in movieclip-lockroot-loadmovie-6.swf.trace-gnash, log in movieclip-lockroot-loadmovie-6.swf.log)

Gabriele Giacone <gg0>
Project Member
Sat 22 Jan 2011 07:21:30 PM UTC, comment #5:

I believe this bug can be closed as fixed.

Petter Reinholdtsen <pere>
Project Member
Fri 21 Jan 2011 04:15:07 PM UTC, comment #4:

As far as I can see, the remaining failing test is a different one:

FAIL: run_swfdec_testsuite_m: movieclip-lockroot-loadmovie-6.swf:679b3cea0d9643744aa29c88ae9908e1 (traces in movieclip-lockroot-loadmovie-6.swf.trace-gnash, log in movieclip-lockroot-loadmovie-6.swf.log)

Anonymous
Fri 21 Jan 2011 04:08:26 PM UTC, comment #3:

Applied patch from ml e05ccb787a4f4809c8b65e6d4e067015f805a670

Though mentioned failed test is still there

Gabriele Giacone <gg0>
Project Member
Thu 20 Jan 2011 09:10:50 PM UTC, comment #2:

yes, should be created all the times.
Gabriele, will you take care of this ? I'm sure Petter has a patch :)

Sandro Santilli <strk>
Project Member
Thu 20 Jan 2011 08:34:32 PM UTC, comment #1:

Sandro Santilli mentioned on IRC that the WIN value is fetched from testsuite/gnashrc, which is missing when building on Lenny.

The cause is found in testsuite/Makefile.am:

if ENABLE_MING

.PHONY: Dejagnu.swf
Dejagnu.swf:
$(MAKE) -C misc-ming.all $@
cp misc-ming.all/Dejagnu.swf $@

check-local: Dejagnu.swf gnashrc

endif

The file is only created when ENABLE_MING is active. Perhaps it should be created all the time?

Petter Reinholdtsen <pere>
Project Member
Thu 20 Jan 2011 06:39:45 PM UTC, original submission:

On Debian/Lenny, One of the tests in the the testsuite fail like this:

FAIL: run_swfdec_testsuite_m: movieclip-version-6.swf:40e09c3d4c0ed3f7763d30c05725ef1a (traces in movieclip-version-6.swf.trace-gnash, log in movieclip-version-6.swf.log)

This is the content of movieclip-version-6.swf.log:

--- /var/lib/buildbot/gnash/build/lenny-linux-x86_32/build/testsuite/swfdec/src/test/trace/movieclip-version-6.swf.trace 2011-01-20 17:33:28.000000000 +0000
+++ movieclip-version-6.swf.trace-gnash 2011-01-20 17:39:20.000000000 +0000
@@ -1,30 +1,30 @@
_level0
-WIN
-WIN
+LNX
+LNX
_level8
-WIN
-WIN
+LNX
+LNX
_level0.m8
undefined
undefined
undefined
_level7
-WIN
-WIN
+LNX
+LNX
_level0.m7
undefined
undefined
undefined
_level6
-WIN
-WIN
+LNX
+LNX
_level0.m6
undefined
undefined
undefined
_level5
-WIN
-WIN
+LNX
+LNX
_level0.m5
undefined
undefined

This make me suspect the test code only work on Windows, but this is hard to believe as the same test code run successfully on Debian/Squeeze, as far as I know.

Petter Reinholdtsen <pere>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by bwy (Updated the item)
  • -unavailable- added by gg0 (Posted a comment)
  • -unavailable- added by strk (Posted a comment)
  • -unavailable- added by pere (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 7 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 13 Mar 2011 04:24:44 PM UTCgg0Summaryswfdec movieclip-version-6.swf test fail (WIN != LNX) on Debian Lenny=>movieclip-lockroot-loadmovie-6.swf on ovh slave
    Sun 13 Mar 2011 04:24:43 PM UTCgg0Assigned togg0=>None
    Sat 19 Feb 2011 03:50:17 AM UTCgg0StatusFixed=>In Progress
      Open/ClosedClosed=>Open
    Sat 22 Jan 2011 07:41:48 PM UTCbwyStatusNone=>Fixed
      Open/ClosedOpen=>Closed
    Thu 20 Jan 2011 09:10:50 PM UTCstrkAssigned toNone=>gg0

    Back to the top


    Powered by Savane 3.1-cleanup