bugGnash - The GNU Flash player - Bugs: bug #30005, flash movies from youtube and...

 
 

bug #30005: flash movies from youtube and facebook don't work

Submitted by:  yehielb <yehielb>
Submitted on:  Mon 31 May 2010 02:36:03 PM UTC  
 
Category: pluginSeverity: 3 - Normal
Release: 0.8.7Status: Need Info
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun 31 Jul 2011 11:20:09 PM UTC, comment #13:

ie: http://static.ak.fbcdn.net/rsrc.php/v1/yW/r/reIZTdNTHIS.swf

Maximiliano Castañón Araneda <maximi89>
Sun 31 Jul 2011 11:09:35 PM UTC, comment #12:

Yehielb, Youtube works, but from Facebook they don't iguess it happens due to the flash cookies.

Maximiliano Castañón Araneda <maximi89>
 Spam posted by an anonymous
Tue 11 Jan 2011 12:51:11 AM UTC, comment #11:

I had to do the same as comment #7 (remove ~/.gstreamer-0.10/registry.i386.bin). Fedora 14 with gstreamer-ffmpeg-0.10.11-1.fc14.i686 rpm installed.

Before that, I got the same messages as comment #5

Anonymous
Wed 15 Dec 2010 04:22:14 AM UTC, comment #10:

This happens with lasted Gnash Master

Maximiliano Castañón Araneda <maximi89>
Wed 15 Dec 2010 03:55:00 AM UTC, comment #9:

Facebook can't reproduce their internal videos, the videos who are stored in Facebook, not youtube links, when this happens it show a message telling it can't play it, probably it's a problem with Local Shared Objects?

Maximiliano Castañón Araneda <maximi89>
Tue 10 Aug 2010 03:29:14 PM UTC, comment #8:

I had the same problem (with youtube and another flash apps, but not all). It seems to be solved deactivating "ubuntu firefox modifications" extension on firefox

Anonymous
Mon 28 Jun 2010 08:31:03 PM UTC, comment #7:

Playing videos is working now.
Just had to remove ~/.gstreamer-0.10/registry.x86_64.bin

Anonymous
Tue 22 Jun 2010 06:15:30 PM UTC, comment #6:

On Youtube I also get the error message that he can't find a x-h264 plugin, though gstreamer0.10-ffmpeg (0.10.10) is installed.
Sound is working, but it isn't playing the video.
I attached the debug-log.

These are the installed gstreamer packages:
ii gstreamer-tools 0.10.29-1 Tools for use with GStreamer
ii gstreamer0.10-alsa 0.10.29-4 GStreamer plugin for ALSA
ii gstreamer0.10-buzztard 0.5.0-2 Buzztard - Support plugins for GStreamer
ii gstreamer0.10-ffmpeg 0.10.10-1 FFmpeg plugin for GStreamer
ii gstreamer0.10-fluendo-mp3 0.10.14.debian-1 Fluendo mp3 decoder GStreamer plugin
ii gstreamer0.10-lame 0.10.15-0.1 GStreamer lame plugin
ii gstreamer0.10-nice 0.0.12-1 ICE library (GStreamer plugin)
ii gstreamer0.10-plugins-bad 0.10.19-1 GStreamer plugins from the "bad" set
ii gstreamer0.10-plugins-base 0.10.29-4 GStreamer plugins from the "base" set
ii gstreamer0.10-plugins-base-apps 0.10.29-4 GStreamer helper programs from the "base" se
ii gstreamer0.10-plugins-cutter 1.1.3-1 Cutter GStreamer plugin
ii gstreamer0.10-plugins-gl 0.10.1-3 GStreamer plugins from the "gl" set
ii gstreamer0.10-plugins-good 0.10.23-4 GStreamer plugins from the "good" set
ii gstreamer0.10-plugins-really-bad 0.10.19-0.0 GStreamer plugins from the "bad" set
ii gstreamer0.10-plugins-ugly 0.10.15-1 GStreamer plugins from the "ugly" set
ii gstreamer0.10-pulseaudio 0.10.23-4 GStreamer plugin for PulseAudio
ii gstreamer0.10-sdl 0.10.19-1 GStreamer plugin for SDL output
ii gstreamer0.10-tools 0.10.29-1 Tools for use with GStreamer
ii gstreamer0.10-x 0.10.29-4 GStreamer plugins for X11 and Pango
ii gstreamer0.10-x264 0.10.15-0.1 GStreamer x264 plugin
ii libgstreamer-plugins-base0.10-0 0.10.29-4 GStreamer libraries from the "base" set
ii libgstreamer-plugins-gl0.10-0 0.10.1-3 GStreamer libraries from the "gl" set
ii libgstreamer0.10-0 0.10.29-1 Core GStreamer libraries and elements

Gnash 0.8.7-2+b1 is installed. Do you require any further information?

(file #20793)

Anonymous
Sat 05 Jun 2010 04:41:58 PM UTC, comment #5:

I installed gstreamer0.10-ffmpeg version 0.10.3-6 (from the package advertised in my gNewSense Synaptic.
I set blocking for cookies for Youtube.com and made sure existing ones were deleted.
I get two Gnash error messages for a video
1."MediaHandlerGst::createAudioDecoder:Couldn't find a plugin for audio type audio/mpeg!--
MediaHandler::createFlashAudioDecoder: no available FLASH decoders for codec 10(Advanced Audio Coding)"
2."Couldn't find a plugin for video type video/x-h264! Please make sure you have the gstreamer-ffmpeg installed."

Dennis Worthem <numi>
Mon 31 May 2010 07:08:55 PM UTC, comment #4:

I had the black screen with the error message on youtube, but now after blocking cookies it's all working great.

on facebook i get a facebook logo, I can't try blocking the cookies because then I won't be logged in...

yehielb <yehielb>
Mon 31 May 2010 03:25:16 PM UTC, comment #3:

I still need information on what "doesn't work". Please describe exactly what is or is not happening. If you get the "an error occurred" message, then try removing all youtube cookie, then block all youtube cookies. If you get a black window with other sites, that usually means they are avm2, which currently isn't barely supported yet.

Rob Savoye <rsavoye>
Project Administrator
Mon 31 May 2010 02:59:40 PM UTC, comment #2:

I installed gstreamer-ffmpeg-0.10.10-1.fc13.i686 and then when trying to view a video from youtube a popup asked for a codec installation, that popup was packagekit then it installed several more packages.

after that that particular video did work, but others did not.

thanks,
YB.

yehielb <yehielb>
Mon 31 May 2010 02:40:09 PM UTC, comment #1:

We need more information that "doesn't work". Often you need to install the ffmpeg-gstreamer plugin, which is what contains all the video and audio codecs.

Rob Savoye <rsavoye>
Project Administrator
Mon 31 May 2010 02:36:03 PM UTC, original submission:

just installed
gnash-plugin-0.8.7-1.fc13.i686
gnash-0.8.7-1.fc13.i686
on
fedora core 13

kernel-PAE-2.6.33.4-95.fc13.i686
kdebase-4.4.2-1.fc13.i686
firefox-3.6.3-4.fc13.i686

flash movies from both youtube and facebook do not work.
thanks,
YB.

yehielb <yehielb>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #20793:  gnash-dbg.log added by None (16KiB)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by maximi89 (Posted a comment)
  • -unavailable- added by numi (Posted a comment)
  • -unavailable- added by rsavoye (Posted a comment)
  • -unavailable- added by yehielb (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 22 Jun 2010 06:15:30 PM UTCNoneAttached File-=>Added gnash-dbg.log, #20793
    Mon 31 May 2010 02:40:08 PM UTCrsavoyeStatusNone=>Need Info

    Back to the top


    Powered by Savane 3.1-cleanup1