bugGNU Wget - Bugs: bug #29316, --dry-run or --print-uri: print...

 
 

bug #29316: --dry-run or --print-uri: print what wget *would* do, but don't do it

Submitted by:  Tom Roche <tomroche>
Submitted on:  Tue 23 Mar 2010 04:20:31 PM UTC  
 
Category: Feature RequestSeverity: 3 - Normal
Priority: 5 - NormalStatus: Wont Fix
Privacy: PublicAssigned to: Giuseppe Scrivano <gscrivano>
Originator Name: Tom RocheOpen/Closed: Open
Release: NoneOperating System: GNU/Linux
Reproducibility: Every TimeFixed Release: None
Planned Release: NoneRegression: No
Work Required: NonePatch Included: None

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 26 Jul 2010 04:50:12 PM UTC, comment #2:

wget has no way to predict what it will do without effectively do it; differently from rsync, wget must download files in order to find links.

The only solution I see is that files should be downloaded in a different temporary directory (when they are newer than the local copy) and use them to going on. Are we sure somebody can benefit from this?

Giuseppe Scrivano <gscrivano>
Project AdministratorIn charge of this item.
Thu 27 May 2010 03:45:57 PM UTC, comment #1:

I don't see how this can be done..

Assume something like:

wget --dry-run -r http://www.foo.bar

How would you know what will be downloaded without really download it?

Giuseppe Scrivano <gscrivano>
Project AdministratorIn charge of this item.
Tue 23 Mar 2010 04:20:31 PM UTC, original submission:

Apologies if 'wget' can already do this, but I've just read all of `info wget` and I'm not seeing it: how to make 'wget' print what it would do, without actually doing it?

I regularly use 'rsync' to move large amounts of data recursively. Being the cautious type, unless I already have an rsync-invoking script for the situation, I iteratively create a script using rsync's --dry-run switch: this allows me to verify whether I am using the appropriate command options relatively rapidly, without enduring a time-wasting (or data-destroying) failure or incompleteness.

'wget' can't destroy data, AFAIK, but like 'rsync'

  • 'wget' also has an {impressive, hard to remember} set of {features, switches, options}
  • I use 'wget' to move some very large files (e.g. multi-gigabyte NetCDFs).

Hence I would like to be able to invoke 'wget' with semantics like `rsync --dry-run`: parse the rest of your options, and tell me what you would download based on the options I have passed, but don't actually download anything.

Note this feature request has been previously asked for @

http://www.mail-archive.com/wget@sunsite.dk/msg07896.html

and seems to be a superset of bug#=20377

https://savannah.gnu.org/bugs/?20377

which refers to the 'apt-get' --print-uri switch. I don't use that but it seems to provide similar semantics.

Implementation-wise, it may be related to these bugs (which point to each other)

https://savannah.gnu.org/bugs/?20645 https://savannah.gnu.org/bugs/index.php?20714

but I'm just guessing there.

TIA, Tom Roche <Tom_Roche@pobox.com>

Tom Roche <tomroche>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by gscrivano (Posted a comment)
  • -unavailable- added by tomroche (Submitted the item)
  •  

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 03 Aug 2011 08:56:58 PM UTCgscrivanoStatusNeeds Discussion=>Wont Fix
    Mon 26 Jul 2010 04:50:12 PM UTCgscrivanoAssigned toNone=>gscrivano
    Thu 27 May 2010 03:45:57 PM UTCgscrivanoStatusNone=>Needs Discussion

    Back to the top


    Powered by Savane 3.1-cleanup1