bugGnash - The GNU Flash player - Bugs: bug #24311, youtube fails on ppc with current...

 
 

bug #24311: youtube fails on ppc with current trunk when using ffmpeg with swscaler enabled

Submitted by:  Miklos Vajna <vmiklos>
Submitted on:  Fri 19 Sep 2008 05:11:15 PM UTC  
 
Category: video-ffmpegSeverity: 3 - Normal
Release: trunkStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sun 12 Oct 2008 11:56:26 AM UTC, comment #9:

I replaced --enable-media=ffmpeg with --enable-media=gst, updated my trunk checkout (to r9976), and now youtube.com works fine on ppc as well!

This does not solve the bug, but earlier I was recommended to use --enable-media=ffmpeg if I want to have a working youtube, so from a user's PoV, there now a working workaround. ;)

Miklos Vajna <vmiklos>
Sat 20 Sep 2008 08:34:53 PM UTC, comment #8:

Ah, I'll investig it further... Hopefully they have re-eenabled the PPC-cluster access for me.

Markus Gothe <nihilus>
Project Member
Sat 20 Sep 2008 04:30:55 PM UTC, comment #7:

That's neither a bug in Gnash nor in Ffmpeg, is it? It's just an opcode valgrind doesn't know (as bjacques pointed out, mentioned here: http://www.nabble.com/-Bug-135264--New:-dcbzl-instruction-missing-td6697340.html).

No one has reported a Gnash bug on avcodec_open.

Benjamin Wolsey <bwy>
Project Member
Sat 20 Sep 2008 04:27:03 PM UTC, comment #6:

==27937==
==27937== Process terminating with default action of signal 4 (SIGILL)
==27937== Illegal opcode at address 0xE206ACC
==27937== at 0xE206ACC: check_dcbzl_effect (in /usr/lib/libavcodec.so.51.56.0)
==27937== by 0xE206B60: dsputil_init_ppc (in /usr/lib/libavcodec.so.51.56.0)
==27937== by 0xDF596C8: dsputil_init (in /usr/lib/libavcodec.so.51.56.0)
==27937== by 0xDFE0FDC: MPV_common_init (in /usr/lib/libavcodec.so.51.56.0)
==27937== by 0xE0A1D38: ff_h263_decode_init (in /usr/lib/libavcodec.so.51.56.0)
==27937== by 0xDFAB384: avcodec_open (in /usr/lib/libavcodec.so.51.56.0)
==27937== by 0xFEECF98: gnash::media::VideoDecoderFfmpeg::init(CodecID, int, int, unsigned char*, int) (VideoDecoderFfmpeg.cpp:163)
==27937== by 0xFEED768: gnash::media::VideoDecoderFfmpeg::VideoDecoderFfmpeg(gnash::media::VideoInfo&) (VideoDecoderFfmpeg.cpp:137)
==27937== by 0xFEE3AC4: gnash::media::MediaHandlerFfmpeg::createVideoDecoder(gnash::media::VideoInfo&) (MediaHandlerFfmpeg.cpp:62)
==27937== by 0xFB3517C: gnash::NetStreamFfmpeg::initVideoDecoder(gnash::media::MediaParser&) (NetStreamFfmpeg.cpp:215)
==27937== by 0xFB35CF0: gnash::NetStreamFfmpeg::startPlayback() (NetStreamFfmpeg.cpp:270)
==27937== by 0xFB36A18: gnash::NetStreamFfmpeg::play(std::string const&) (NetStreamFfmpeg.cpp:189)

Markus Gothe <nihilus>
Project Member
Sat 20 Sep 2008 04:21:27 PM UTC, comment #5:

None of those auto_ptr members should be incomplete at the time of instantiation, which is what counts. Both wrappers are defined in the cpp file and ImageBase is defined in GnashImage.h, which is included. The auto_ptrs will of course be instantiated with the class.

Benjamin Wolsey <bwy>
Project Member
Sat 20 Sep 2008 02:44:29 PM UTC, comment #4:

But the stacktrace does not point towards ffmpeg itself; the segfault comes from within our code.

Bastiaan Jacques <bjacques>
Project Member
Sat 20 Sep 2008 11:47:29 AM UTC, comment #3:

Of course, how else could I point out ffmpeg as the culprit at the first quick look? ;-P

Markus Gothe <nihilus>
Project Member
Sat 20 Sep 2008 01:29:48 AM UTC, comment #2:

Do you confirm your stacktrace is the same as Miklos', Markus?

Bastiaan Jacques <bjacques>
Project Member
Fri 19 Sep 2008 06:15:50 PM UTC, comment #1:

My best guess: "undefined behaviour" resulting from a declaration of a std::auto_ptr from a forward declared class (SwsContextWrapper, Image::ImageBase or CodecContextWrapper) and subsequent deletion on this platform results in a segfault.

Bastiaan Jacques <bjacques>
Project Member
Fri 19 Sep 2008 05:11:15 PM UTC, original submission:

But what is easier to debug:

gtk-gnash http://klaus.geekserver.net/flash/video.swf

currently fails on ppc.

See here:

http://lists.gnu.org/archive/html/gnash/2008-09/msg00015.html

Backtrace and valgrind output is included in the thread.

In case I forgot to mention any interesting detail, please let me know.

Thanks!

Miklos Vajna <vmiklos>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by bwy (Posted a comment)
  • -unavailable- added by nihilus (Updated the item)
  • -unavailable- added by bjacques (Posted a comment)
  • -unavailable- added by vmiklos (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 20 Sep 2008 10:14:49 PM UTCbjacquesStatusConfirmed=>None
    Sat 20 Sep 2008 01:20:39 AM UTCnihilusStatusNone=>Confirmed

    Back to the top


    Powered by Savane 3.1-cleanup1