bugfindutils - Bugs: bug #22352, Find does not work in a root disk

 
 

bug #22352: Find does not work in a root disk

Submitted by:  None
Submitted on:  Mon 18 Feb 2008 04:16:25 AM UTC  
 
Category:  find Severity:  3 - Normal
Item Group:  Wrong result Status:  Invalid
Privacy:  Public Assigned to:  Eric Blake <ericb>
Originator Name:  Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.2.32
Fixed Release:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 18 Feb 2008 12:52:52 PM UTC, comment #2: 

This is not a bug in find, but a limitation of cygwin and your current permissions for the root drive; the cygwin list archives already detail several people who have dealt with poor root drive permissions.  Also, you mention 4.2.32, which implies you built findutils yourself; while cygwin currently ships with find 4.3.13 prebuilt and with any necessary cygwin-specific patches folded in as part of the official cygwin distribution - I highly recommend using the cygwin port of findutils rather than rolling your own.  One of the differences here is that 4.3.x uses fts() rather than a home-grown traversal algorithm, which may perform better given poor permissions on the root drive.  At any rate, if this is still a problem for you, you should contact <cygwin AT cygwin DOT com>, since it is not an upstream bug.

One last point - you mentioned using:
find $PWD -name "*.bat"

That is quoted incorrectly.  You should get in the habit of using one of the following equivalent actions (the first two are required by POSIX, the last is a GNU extension):
find "$PWD" -name "*.bat"
find . -name "*.bat"
find -name "*.bat"

Eric Blake <ericb>
Project AdministratorIn charge of this item.
Mon 18 Feb 2008 11:01:19 AM UTC, comment #1: 

This works for me on non-Cygwin systems.   I don't have access to a Cygwin system with which to reproduce this error.  If you have not already done so, I think it would be useful for you to discuss the problem on the Cygwin mailing list, as it looks to me as if the problem may be specific to Cygwin.  Thanks.

James Youngman <jay>
Project Administrator
Mon 18 Feb 2008 04:16:25 AM UTC, original submission:  

My PC environment is Cygwin.

Message as below:

cnh59411@cnhpekcrb2nb411 /cygdrive/n
$ pwd
/cygdrive/n

cnh59411@cnhpekcrb2nb411 /cygdrive/n
$ find $PWD -name "*.bat"
find: .: No such file or directory
find: /cygdrive/n/abti: No such file or directory
find: /cygdrive/n/tattop: No such file or directory
.......

cnh59411@cnhpekcrb2nb411 /cygdrive/n
$ find --version
GNU find version 4.2.32

cnh59411@cnhpekcrb2nb411 /cygdrive/n
$ cd tattop/

cnh59411@cnhpekcrb2nb411 /cygdrive/n/tattop
$ find $PWD/* -name "*.bat"
/cygdrive/n/tattop/modules/dvtop/input/dlldv00top/Makefile.bat
/cygdrive/n/tattop/modules/dvtop/input/dlldv00top/GenericMakefile.bat
/cygdrive/n/tattop/modules/tatdv/input/prj_config.bat
/cygdrive/n/tattop/output/tatselect.bat
/cygdrive/n/tattop/output/pc_tatselect.bat

----------------------------------
But when I change the "findutils" to "GNU find version 4.1.7", it works well.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ericb (Posted a comment)
  • -email is unavailable- added by jay (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2008-02-18 ericb Item GroupCompilation Failure => Wrong result
        StatusNone => Invalid
        Assigned toNone => ericb
        Open/ClosedOpen => Closed
        SummaryFind does not work in a rood disk => Find does not work in a root disk

    Back to the top


    Powered by Savane 3.5