buglibffcall - foreign function call libraries - Bugs: bug #22095, Possibly wrong code on hppa/ia64

 
 

bug #22095: Possibly wrong code on hppa/ia64

Submitted by:  Hubert Chathi <uhoreg>
Submitted on:  Wed 23 Jan 2008 09:10:55 PM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: Not a Bug
Privacy: PublicAssigned to: Bruno Haible <haible>
Open/Closed: Closed

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 02 Feb 2017 11:32:19 PM UTC, comment #1:

Thank you for the notice.

It may be true that on HPPA, there exists two kinds of function pointers: pointers to code, marked with a bit 1 set, and pointer to a two-word structure, marked with bit 1 clear.

But the alloc_trampoline_r function allocates one of the first kind; therefore it is sufficient to test for a function pointer of the first kind in is_trampoline_r.

If a bug in this area would show up, the unit test would show it. "make check" would fail.

Bruno Haible <haible>
Project AdministratorIn charge of this item.
Wed 23 Jan 2008 09:10:55 PM UTC, original submission:

I received the following bug report via the Debian Bug Tracking System (http://bugs.debian.org/457930):

I recently compiled ffcall with a snapshot for 4.3 on hppa and got an
internal compiler error. Upstream fixed this bug, but he also had
some comments about ffcall (namely about trampoline.c):

"I have to say that the code in the original testcase is probably very
wrong for hppa. Like ia64, function pointers point to function
descriptors (when the plabel bit is set). The function descriptor
also may point to a stub and not the function code."
(this is from <http://gcc.gnu.org/bugzilla/show_bug.cgi?id=34525>)

Maybe that's something you can investigate; hopefully the ia64 and
hppa porters can provide some help.

Hubert Chathi <uhoreg>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by haible (Posted a comment)
  • -unavailable- added by sds (Updated the item)
  • -unavailable- added by uhoreg (Submitted the item)
  • -unavailable- added by uhoreg (Debian BTS)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 02 Feb 2017 11:32:19 PM UTChaibleStatusNone=>Not a Bug
      Open/ClosedOpen=>Closed
    Sun 27 Jan 2008 05:35:24 AM UTCsdsAssigned toNone=>haible
    Wed 23 Jan 2008 09:10:55 PM UTCuhoregCarbon-Copy-=>Added -unavailable-

    Back to the top


    Powered by Savane 3.1-cleanup1