taskGNU Astronomy Utilities - Tasks: task #14317, New name for the Arithmetic...


You are not allowed to post comments on this tracker with your current authentication level.

task #14317: New name for the Arithmetic program and library

Submitted by:  Mohammad Akhlaghi <makhlaghi>
Submitted on:  Sat 21 Jan 2017 05:32:44 PM UTC  
Should Start On:  Sat 21 Jan 2017 03:00:00 PM UTC Should be Finished on:  Sat 21 Jan 2017 03:00:00 PM UTC
Category:  Arithmetic Priority:  5 - Normal
Item Group:  Enhancement Status:  Postponed
Privacy:  Public Percent Complete:  0%
Assigned to:  None Open/Closed:  Open
Effort:  0.00

Thu 01 Jun 2017 09:46:22 PM UTC, comment #5: 

There were too many important things to manage, check, and fix before the 0.3 release. So let's leave this issue open and hopefully do it by the next release.

Mohammad Akhlaghi <makhlaghi>
Project Administrator
Mon 23 Jan 2017 01:41:07 PM UTC, comment #4: 

Thanks, this is also an interesting suggestion. I am just thinking how "transform" can be confused with "warping" as described in that same paragraph. But there is still some time left to the 0.3 release so we won't need to make any decisions now. If anything else comes to your mind, please share it here ;-)...

Just as a side-note, as described in in task #14301, the `Image', or `img' prefix to some of the program names will be removed in later versions of Gnuastro (maybe the 0.4 or 0.5 versions). I am really excited by the root data structure of task #14245, it has made this and many other great new features possible.

Mohammad Akhlaghi <makhlaghi>
Project Administrator
Mon 23 Jan 2017 09:54:28 AM UTC, comment #3: 

Inspired by the opening paragraph of the ImageWarp help page, perhaps this is the perfect place to use the word 'transform'? I.e.: ImageTransform / astimgtrans.

Alternatively, and in direct conflict with task 14316, perhaps changing all GNU Astro software to use infinitive verbs (_crop, _rotate, _label) would allow for the continued use of _arith, having the bonus side effect of shortening filename lengths?


Lee Kelvin <leeskelvin>
Project Member
Sat 21 Jan 2017 06:19:46 PM UTC, comment #2: 

Thanks, this was very an interest suggestion.

Let's keep this task open until the 0.3 release to allow for better brainstorming.

Mohammad Akhlaghi <makhlaghi>
Project Administrator
Sat 21 Jan 2017 05:46:18 PM UTC, comment #1: 

Something like "Calculate"?

Mosè Giordano <giordano>
Project Member
Sat 21 Jan 2017 05:32:44 PM UTC, original submission:  

Initially the Arithmetic program (and now the `gal_arithmetic_*' library functions) had a very limited number of operators (the arithmetic operators of `+', `-', `*', and `/', and a few other useful ones. So the name "Arithmetic" was meaningful. But now, it has many operators (all the operators in C, including bitwise operators, many math functions and also type converters).

You can see the full list of the "Arithmetic" operators in the `gal_arithmetic_operators' enumerator of lib/gnuastro/arithmetic.h (currently on my development fork as part of task #14245).

So I think we should find a better name for this program, which is also a verb, not a name. Something like "Operate" for example, but "Operate" doesn't really sound/feel too good.

If anything comes to your mind, please share your thoughts on this task. The name is very important and this program/library will by nature be used a lot. So any ideas would be greatly appreciated.

Mohammad Akhlaghi <makhlaghi>
Project Administrator


No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -email is unavailable- added by leeskelvin (Posted a comment)
  • -email is unavailable- added by giordano (Posted a comment)
  • -email is unavailable- added by makhlaghi (Submitted the item)

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.




    No changes have been made to this item

    Back to the top

    Powered by Savane 3.5