helpGNU Libtool - Support: sr #102347, AIX whole_archive_... revisited

 
 

sr #102347: AIX whole_archive_... revisited

Submitter:  AT <thomason>
Submitted:  Mon 11 Aug 2003 10:58:57 PM UTC
 
Category:  None Priority:  5 - Normal
Severity:  2 - Minor Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open Operating System:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Mon 11 Aug 2003 10:58:57 PM UTC, original submission:  

Since CVS revision 1.294 my convenience library on AIX
has broken.  This seems to be because that patch
removes $convenience from $deplibs, but AIX (at least
with my configuration) has $whole_archive_flag_spec='
'.  This problem was anticipated by chrisp in reply to
support #100049 on Sun 09/09/2001.  There was a
discussion on the libtool list in May '01 regarding the
empty $whole_archive_flag_spec, but apparently there
was never a resolution (libtool.m4 in today's cvs still
contains _LT_AC_TAGVAR(whole_archive_flag_spec, $1)=' '
at line 2859).

Is this a bug introduced by the 1.294 patch or is there
a way around it for AIX?

-Adam Thomason

P.S. This aside, libtool has made my life much easier;
thanks to all the developers for their efforts.

AT <thomason>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

Only logged-in users can vote.

 

 

 

 

No changes have been made to this item

Back to the top


Powered by Savane 3.9