bugMIT/GNU Scheme - Bugs: bug #61988, load problem on Mac with...

 
 

bug #61988: load problem on Mac with M1-processor

Submitter:  None
Submitted:  Thu 03 Feb 2022 06:34:44 PM UTC
 
Category:  None Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Need Info Privacy:  Public
Assigned to:  None Originator Name: 
Originator Email:  -email is unavailable- Open/Closed:  Open
Keywords: 
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Fri 10 Jun 2022 03:06:00 PM UTC, comment #1: 

The 9.x series is no longer supported at this point.  Does this still happen with MIT Scheme 11.2?

Taylor R. Campbell <riastradh>
Project Member
Thu 03 Feb 2022 06:34:44 PM UTC, original submission:  

MIT Scheme Release 9.2 with microcode 15.3 and Runtime 15.7, Edwin 3.116

Everything seems to run fine, except for (load "filename")

1 ]=> (load "explicit")

;Loading "explicit.scm"...
;The port #[input-port 13 for file: "/Users/kjell/git/lisp/explicit.scm"] signalled an error:
The primitive channel-read, while executing the read system call, received the error: Bad address.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by riastradh (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2022-06-10 riastradh StatusNone Need Info

    Back to the top


    Powered by Savane 3.9