bugGnash - The GNU Flash player - Bugs: bug #58759, Compiling fail with errors about...

 
 

bug #58759: Compiling fail with errors about installed libraries

Submitted by:  Balaco <balacobaco>
Submitted on:  Mon 13 Jul 2020 06:23:40 AM UTC  
 
Category:  None Severity:  3 - Normal
Release:  0.8.9 Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 13 Jul 2020 06:23:40 AM UTC, original submission:  

I have a Debian system, and everything installed for gnash 0.8.9. But the configure script fails with this error:

==================
$  ./configure
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... gcc

[...] # some output removed, it should not matter

checking for library containing lt_dlinit... -lltdl
checking for libltdl library... -lltdl 
checking for library containing mallinfo... none required
checking for the gtk2 header... -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/freetype2
checking for libgtk2 library... -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype
checking for the Pango Version... 1.0
checking for libpango header... -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include
checking for libpango library... -lpangox-1.0 -lX11 -lpango-1.0 -lgobject-2.0 -lglib-2.0
checking for atk/atk.h header using pkg-config... -I/usr/include/atk-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include
checking for atk/atk.h header... -I/usr/include/atk-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include
checking for libatk library using pkg-config... -latk-1.0 -lgobject-2.0 -lglib-2.0
checking for the Gtk GL Extensions Version... 1.0
checking for gtk/gtkgl.h... -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/gtkglext-1.0 -I/usr/lib/gtkglext-1.0/include
checking for GTK GL library... -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/gtkglext-1.0 -I/usr/lib/gtkglext-1.0/include
(cached) checking for cairo.h header... -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng16
(cached) checking for libcairo library... -lcairo

[...] # some output removed, it should not matter

checking for pselect... yes
checking for ppoll... yes
configure: creating ./config.status
config.status: creating gnash.pc
config.status: creating desktop/gnash-gtk-launcher
config.status: creating desktop/gnash-qt-launcher

[...] # some output removed, it should not matter

config.status: creating cygnal/testsuite/cygnal.all/Makefile
config.status: creating gnashconfig.h
config.status: gnashconfig.h is unchanged
config.status: linking cygnal/testsuite/cygnal.all/cygnalrc.in to cygnal/testsuite/cygnal.all/cygnalrc
config.status: linking testsuite/libbase.all/gnashrc.in to testsuite/libbase.all/gnashrc
config.status: linking testsuite/libbase.all/gnashrc-local.in to testsuite/libbase.all/gnashrc-local
config.status: executing depfiles commands
config.status: executing po-directories commands
config.status: executing libtool commands

Configurable options are:
        DMalloc support disabled (default). Use --enable-dmalloc to enable.
        NPAPI plugin enabled (default). Use --disable-npapi to disable.
            NPAPI plugin will be installed in /home/user/.mozilla/plugins
        KPARTS 3.x plugin disabled.
        KPARTS 4.x plugin disabled.
Configured paths for x86_64-unknown-linux-gnu are:
        JPEG flags are: default include path
        JPEG libs are: -ljpeg
        GIF flags are: default include path
        GIF libs are: -lgif -lz -lrt -lX11 -lltdl 
        PNG flags are: -I/usr/include/libpng16
        PNG libs are: -lpng16
        OpenGL flags are: default include path
        OpenGL libs are: -lGL -lGLU
        GtkGLExt flags are: -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/gtkglext-1.0 -I/usr/lib/gtkglext-1.0/include
        GtkGLExt libs are: -lgtkglext-x11-1.0 -lgdkglext-x11-1.0 -lGLU -lGL -lXmu -lXt -lSM -lICE -lgdk-x11-2.0 -lpangox-1.0 -lX11 -lgmodule-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype
        GTK2 flags are: -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/freetype2
        GTK2 libs are: -lgtk-x11-2.0 -lgdk-x11-2.0 -lpangocairo-1.0 -latk-1.0 -lcairo -lgdk_pixbuf-2.0 -lgio-2.0 -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 -lfontconfig -lfreetype
        Pango flags are: -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include
        Pango libs are: -lpangox-1.0 -lX11 -lpango-1.0 -lgobject-2.0 -lglib-2.0
        GLib flags are: -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include
        GLib libs are: -lglib-2.0
        ATK flags are: -I/usr/include/atk-1.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include
        ATK libs are: -latk-1.0 -lgobject-2.0 -lglib-2.0
        Cairo flags are: -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng16
        Cairo libs are: -lcairo
        SDL flags are: -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT
        SDL libs are: /x86_64-linux-gnu -lSDL
        AGG Pixel format is: all
        AGG flags are: -I/usr/include/agg2
        AGG libs are: -lagg_pic
        PERL is /usr/bin/perl
        Z flags are: default include path
        Z libs are: -lz -lrt -lX11 -lltdl 
        FreeType flags are: -I/usr/include/freetype2
        FreeType libs are: -lfreetype
        Fontconfig flags are: -I/usr/include/freetype2
        Fontconfig libs are: -lfontconfig -lfreetype
        DEJAGNU's runtest is /usr/bin/runtest
        LIBLTDL flags are:
        LIBLTDL libs are: -lltdl 
        Only building these ActionScript classes into the library:

    

        You have netcat installed, which is only used for testing
        You have wget installed, which is only used for testing
--------
        Building Cygnal media server disabled.
        Top level for cross compiling support files is:
        Enabling security features:  localconnection
        Enabling hardware acceleration features:
        Enabling statistics collecting for:  cache
        GUI toolkits supported: fb,gtk,sdl,dump
        Renderers supported: AGG Cairo OpenGL
        Hardware Acceleration:
        Media handlers: gst
        Using sdl for sound handling
        Using  mode for shared memory
        DocBook document processing disabled (default)
        Using PS/2 Mouse, Input Devices, Touchscreen via Tslib for Input

        WARNING: without --enable-docbook we will use the cached
                 documentation files included in the gnash distribution.
                 If you change files in doc/C, you should --enable-docbook.
        WARNING: You need to have the Ming development package
                 installed to run most of the tests in Gnash testsuite.
                 Install it from http://www.libming.org/
                 or .deb users: apt-get install libming-dev
        WARNING: You need to have the Ming utilities package
                 version 0.4 or higher installed to run
                 many of the tests in Gnash testsuite.
                 Install it from http://www.libming.org
                 or .deb users: apt-get install libming-util
        WARNING: You need to have the MTASC compiler packages installed
                 to run some of the tests in Gnash testsuite.
                 You can install it from http://mtasc.org
                 or .deb users: apt-get install mtasc
        WARNING: You need to have the HAXE compiler package
                 version 2.00 or higher installed
                 to run some of the tests in Gnash testsuite.
                 You can install it from http://haxe.org
                 or .deb users: apt-get install haxe
        WARNING: You need to have the 'swfmill' tool installed
                 to run some of the tests in Gnash testsuite.
                 You can install it from http://swfmill.org/
                 or .deb users: apt-get install swfmill
        WARNING: You need to have 'swfc' from SWFTools installed
                 to run some of the tests in Gnash testsuite.
                 You can install it from http://www.swftools.org/
                 or .deb users: apt-get install swftools
        WARNING: you need as3compile from SWFTools
                 to run some of the tests in Gnash testsuite.
                 You can install it from http://www.swftools.org/

Gnash should still compile even with these warnings.
If it doesn't, report the warnings as a bug.

        RECOMMENDED: If you install the CURL library, Gnash will be able to
                     display remote content (streaming from URLs) using CURL.
                     Install libcurl from http://curl.haxx.se/libcurl
                     or .deb users: apt-get install libcurl-dev
                     or .rpm users: yum install curl-devel
        RECOMMENDED: If you install the Speex library, Gnash will be able to
                     decoded Speex encoded audio in FLV files.
                     Install libspeex from http://speex.org
                     or .deb users: apt-get install libspeex-dev
                     or .rpm users: yum install speex-devel

Gnash should still compile, but you'll miss important support

        ERROR: GST media handling requested but gstreamer-0.10+ not found
               Install it from http://www.gstreamer.net
               or .deb users: apt-get install libgstreamer0.10-dev
               or .rpm users: yum install gstreamer-devel
               or             yast install gstreamer010-devel
        ERROR: No BOOST development package installed!
               Install it from http://www.boost.org
               or .deb users: apt-get install libboost-dev libboost-thread-dev
               or .rpm users: yum install boost-devel
        ERROR : No xulrunner development package is installed
                Install it from http://releases.mozilla.org/pub/mozilla.org/xulrunner
                or .deb users: apt-get install xulrunner-dev
                or .rpm users: yum install xulrunner-devel
configure: error: Please install required packages

$
==================

The warnings can be left as is to compile. Fine. But there are 3 errors, complaining of packages:

1. libgstreamer0.10-dev

A newer version is installed:
------------
$  aptitude search libgstreamer

p   libgstreamer-ocaml              - OCaml interface to the gstreamer library -
p   libgstreamer-ocaml:i386         - OCaml interface to the gstreamer library -
v   libgstreamer-ocaml-5f1y4:i386   -                                          
p   libgstreamer-ocaml-dev          - OCaml interface to the gstreamer library -
p   libgstreamer-ocaml-dev:i386     - OCaml interface to the gstreamer library -
v   libgstreamer-ocaml-dev-5f1y4:i3 -                                          
v   libgstreamer-ocaml-dev-dh5s9    -                                          
v   libgstreamer-ocaml-dh5s9        -                                          
i A libgstreamer-plugins-bad1.0-0   - arquivos de desenvolvimento GStreamer para
p   libgstreamer-plugins-bad1.0-0:i - arquivos de desenvolvimento GStreamer para
p   libgstreamer-plugins-bad1.0-dev - GStreamer development files for libraries
p   libgstreamer-plugins-bad1.0-dev - GStreamer development files for libraries
i   libgstreamer-plugins-base0.10-0 - GStreamer libraries from the "base" set  
i A libgstreamer-plugins-base1.0-0  - bibliotecas GStreamer do conjunto "base" 
p   libgstreamer-plugins-base1.0-0: - bibliotecas GStreamer do conjunto "base" 
p   libgstreamer-plugins-base1.0-de - GStreamer development files for libraries
p   libgstreamer-plugins-base1.0-de - GStreamer development files for libraries
i   libgstreamer0.10-0              - Core GStreamer libraries and elements    
i A libgstreamer1.0-0               - bibliotecas e elementos GStreamer centrais
p   libgstreamer1.0-0:i386          - bibliotecas e elementos GStreamer centrais
p   libgstreamer1.0-0-dbg           - Bibliotecas e elementos do nĂșcleo da GStre
p   libgstreamer1.0-0-dbg:i386      - Bibliotecas e elementos do nĂșcleo da GStre
i   libgstreamer1.0-dev             - GStreamer core development files         
p   libgstreamer1.0-dev:i386        - GStreamer core development files         
p   libgstreamermm-1.0-1            - C++ wrapper library for GStreamer (shared
p   libgstreamermm-1.0-1:i386       - C++ wrapper library for GStreamer (shared
p   libgstreamermm-1.0-dev          - C++ wrapper library for GStreamer (develop
p   libgstreamermm-1.0-dev:i386     - C++ wrapper library for GStreamer (develop
p   libgstreamermm-1.0-doc          - C++ wrapper library for GStreamer (documen
v   libgstreamermm-1.0-doc:i386     -                                          

$

------------

2. libboost-dev libboost-thread-dev

Both exist:
------------
$  aptitude search libboost-dev libboost-thread-dev

i   libboost-dev                    - Boost C++ Libraries development files (def
i   libboost-thread-dev             - portable C++ multi-threading (default vers

$
------------

3. xulrunner-dev

What should i do about xulrunner? It is not in Debian repositories, and i saw a few warnings about it. For example:

https://packages.qa.debian.org/x/xulrunner.html

https://linuxsecurity.com/advisories/debian/debian-new-xulrunner-packages-fix-arbitrary-code-execution

Balaco <balacobaco>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #49476:  t added by balacobaco (35KiB - application/octet-stream - Full output of the configure script, obtained with the command './configure >t 2>1' )

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by balacobaco (Submitted the item)
  • -email is unavailable- added by balacobaco
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-07-13 balacobaco Attached File- => Added t, #49476
        Carbon-Copy- => Added balacobaco

    Back to the top


    Powered by Savane 3.6