bugGforth - Bugs: bug #57324, does not install on Windows 10 LSM

 
 

bug #57324: does not install on Windows 10 LSM

Submitted by:  None
Submitted on:  Fri 29 Nov 2019 05:16:18 AM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  Works For Me
Privacy:  Public Assigned to:  Bernd Paysan <paysan>
Open/Closed:  Open

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 02 Dec 2019 09:52:08 AM UTC, comment #4: 

Can you do

rm -rf lib
make libcc

and provide me with the output log if that fails?

Bernd Paysan <paysan>
Project AdministratorIn charge of this item.
Mon 02 Dec 2019 05:51:14 AM UTC, comment #3: 

(updated) strangely even though the 'make install' says it failed on those libraries, when I run gforth, it says that the version is now 0.7.3

So, it installed at least partially.

Anonymous
Mon 02 Dec 2019 05:48:21 AM UTC, comment #2: 

Thanks.  Following you comment, I tried `sudo make clean` followed by `sudo ./install-deps.sh` and `./BUID-FROM-SCRATCH` and `sudo make install`

Unfortunately, I still get 'libtool:   error: 'lib/gforth/0.7.9_20191128/amd64/libcc-named/libgfcstr.la' is not a valid libtool archive'   and on libgfsocket.la libgfmmap.la libgfserial.la libgffilestat.la libgflibffi.la and libgftime.la

I might have to figure out how to do a completely clean install.  In the meantime, gforth 7.2 installs ok from apt-get, so I'll run with that for the moment.

Anonymous
Sat 30 Nov 2019 03:01:48 PM UTC, comment #1: 

Dependencies to install are in the install-deps.sh script. If you don't use this script, chances are high that you miss something, e.g. libtool-bin; without, libtool fails in interesting ways.

I'll update INSTALL.md, which describes how to install from git.

Bernd Paysan <paysan>
Project AdministratorIn charge of this item.
Fri 29 Nov 2019 05:16:18 AM UTC, original submission:  

I tried following the instructions for installing from the git repository on ubuntu linux (windows linux submodule) and ran into several issues.  Firstly, the following dependency packages also need installing: automake, libpcre3, libpcre3-dev, flex, bison, texinfo

Even after that, I get the following error upon `sudo make install` :

libtool:   error: 'lib/gforth/0.7.9_20191128/amd64/libcc-named/libgfcstr.la' is not a valid libtool archive

The same error also flags libgfsocket.la libgfmmap.la libgfserial.la libgffilestat.la libgftime.la libgflibffi.la

How can the libtool errors be resolved?

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by paysan (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-11-30 paysan StatusNone => Works For Me
        Assigned toNone => paysan

    Back to the top


    Powered by Savane 3.6