bugGNU Common Lisp - Bugs: bug #56868, FORMAT doesn't support Tilde Slash

 
 

bug #56868: FORMAT doesn't support Tilde Slash

Submitted by:  None
Submitted on:  Sat 07 Sep 2019 06:20:08 PM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 07 Sep 2019 06:20:08 PM UTC, original submission:  

It appears that GCL doesn't support Tilde Slash in FORMAT (http://www.lispworks.com/documentation/lw50/CLHS/Body/22_ced.htm).

I tried with the tarball labeled 2.6.12 and dated 2014 on the download page which is the most recent tarball from what I can tell. I wasn't able to build from Git so I don't know if this has been implemented in the meantime.

E.g.:

>(format t "~/pprint-linear/~%" '(1 2 3))


Error:
Fast links are on: do (si::use-fast-links nil) for debugging
Signalled by FORMAT.
Condition in FORMAT [or a callee]: INTERNAL-SIMPLE-ERROR: Format error: illegal directive.
  V
"~/pprint-linear/~%"

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

 

 

No changes have been made to this item

Back to the top


Powered by Savane 3.6