bughello - GNU greeting package - Bugs: bug #53493, Cannot generate documentation

 
 

bug #53493: Cannot generate documentation

Submitter:  Jorge <jorgesumle>
Submitted:  Wed 28 Mar 2018 04:08:11 AM UTC
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

( Jump to the original submission )

Mon 02 Apr 2018 08:52:59 AM UTC, comment #7: 

After running: ./bootstrap --gnulib-srcdir=/home/ben/Sources/gnulib --no-git --skip-po  &&  ./configure  &&  make, the version.texi file had appeared in the doc/ subdirectory.  The final make is what generated it.  So, first run make in the top source directory -- as one always should.

Benno Schulenberg <bens>
Sun 01 Apr 2018 11:21:47 PM UTC, comment #6: 

> Probably you need to run the ./bootstrap script?


I already did that, but that didn't create the file.

Jorge <jorgesumle>
Sun 01 Apr 2018 05:22:52 PM UTC, comment #5: 

I don't know how to generate the file -- I used the 2.10 tarball.

Probably you need to run the ./bootstrap script?

Benno Schulenberg <bens>
Sun 01 Apr 2018 03:56:32 PM UTC, comment #4: 

I can't see that file after cloning the repository. Look, it doesn't exist: http://git.savannah.gnu.org/cgit/hello.git/tree/doc.

How do you generate it?

Jorge <jorgesumle>
Sun 01 Apr 2018 08:13:53 AM UTC, comment #3: 

Did you change something in the makefiles?  Because the file is right there: doc/version.texi.  Or maybe your tools are too old?

Benno Schulenberg <bens>
Sun 01 Apr 2018 01:19:43 AM UTC, comment #2: 

> Where did you get texi2html from? It does not exist on my system.


It's a package. See https://packages.debian.org/stretch/texi2html

> When using texi2any, it works fine:


> texi2any --html --no-split doc/hello.texi


The same issue with that command, as the files are still not found.

$ texi2any --html --no-split doc/hello.texi
doc/hello.texi:4: @include: could not find version.texi
doc/hello.texi:5: warning: undefined flag: VERSION
doc/hello.texi:15: warning: undefined flag: VERSION
doc/hello.texi:15: warning: undefined flag: UPDATED
doc/hello.texi:40: warning: undefined flag: VERSION
doc/hello.texi:40: warning: undefined flag: UPDATED
doc/hello.texi:54: warning: undefined flag: VERSION
doc/hello.texi:54: warning: undefined flag: UPDATED
doc/hello.texi:313: @include: could not find fdl.texi

Jorge <jorgesumle>
Sat 31 Mar 2018 08:42:26 AM UTC, comment #1: 

Where did you get texi2html from?  It does not exist on my system.

When using texi2any, it works fine:

  texi2any --html --no-split  doc/hello.texi

produces a hello.html.

Benno Schulenberg <bens>
Wed 28 Mar 2018 04:08:11 AM UTC, original submission:  

There are some missing files:

$ texi2html hello.texi
*** Can't find version.texi, skipping (l. 4)
*** Can't find fdl.texi, skipping (l. 313)

Jorge <jorgesumle>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bens (Posted a comment)
  • -email is unavailable- added by jorgesumle (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.9